Unable to comission

I am using my Samsung Galaxy Nexus, which should be fine, to commission my imp, but for over an hour of trying I am now close to giving up.

I have double/tribble/quad… checked the SSID key, tried with two different access points which my phone easily connect to, tried various ways of shielding the sensor from ambient light, and still I just get a quick red flash after blinkup, then slow blinking for about a minute before stopping all blinking.

What to try next? And is this really the only way to do it? I had plans of getting a bunch of imps for some small projects, but if I need to spend this much time without even getting it to connect, I am not sure this is ready for any use yet…

I faced the same problem. I spent many hours to search for this solution over the net and many hours more to try to commission electric imp.
I am ready to look for alternative product.

Look for the information about the Windows-based app.

I cannot understand the problems, the 'Imp guys seem to be oddly unresponsive to solving the problems. I have gotten mine to commission but I dread the task - it is so hard.

We will be pushing an android update, but as I’ve noted many times on this forum, email/PM us if you want the half-speed version, which is compatible with many more android devices.

Because android has a very pathetic approach to frame rate control, even hugely overpowered phones drop frames regularly - hence running at half speed is about the only way to get this working.

Could you guys put the working/slower version of the blink-up on the store? People could email you to get the fast version if they don’t want to wait a few extra seconds.

I would rather spend a few seconds waiting for one that works, then 10 minutes or longer doing multiple attempts until luck strikes.

We need to do some tidying first I’m afraid, as it’s not suitable for posting in its current form.

Just to close this one, I did end up getting the imp commissioned. To do it I had to use WPS, after a few attempts it did manage to get the message transferred to the imp, but the longer message with the SSID and key for that was too long to get over successfully.

Yep, that’s the sign that you’d be helped by the half-speed version. This allows compensation for dropped frames - the longer the transmission, the more possibility of dropped frames.

why not implement alternative method to define Wifi configuration ?

Because this one works perfectly on iOS, and when we have it working perfectly on Android and in-browser, there’s no need for another method.

I try android version and windows version but i see only red blink - never orange/green. Also i make super lights LED for blinkup but with bit time ~ 16mS imp also not configured. What time for bit for success blinkup ?

Are you covering the side of the imp when you do this to ensure that ambient light isn’t causing issues? (this is only an issue with imps in housing-less devboards).

If blinkup works, ie the CRC is correct on the packet, you will see a brief green flash at the end of the process - just as the phone’s flashing stops - indicating that the data was received correctly. If you see red flashes at this point, then the data was corrupted and you need to retry.

I’ll prepare small video and publish it in short.
Thanks for your helps in advance.


I am having issues commissioning my imp. I have manged to use BlinkUp to set the code, but now the imp flashes orange/red.

My router is sky broadband router, and as far as I can tell no ports are blocked. Can you please let me know what do I need to do.



Anyone ?! Any suggestions ?

Can you give more details - did blinkup work (green flash at the end), are you using android (are there quotes around the SSID name?), etc?

After a long trial an error, I finally managed to setup the imp. I think the documentation needs to be improved a lot more, especially for the beginners. It took me 3 days to set it up and run the hello world example !!

Now, I have another question. If I setup an isolated WiFi network without internet connection, would I still be able to send commands to imp, or does it need to have internet connection?

You can’t communicate with the Imp directly

So, if I use imp to control lights/other devices in some remote location that have very slow internet connection, then it will take up to 5 secs before the lights turn on ?!!

Or, if hackers decide to attack imp’s site does that mean that no imps will work anywhere until the site is up and running ?!! Or even worse is someone hacks the imp’s site they gain control of all the imps ?!!

If this is a case it is such a shame! I really loved the idea and the product, but unfortunately with these limitations, I definitively won’t be able to use it on my products :frowning:

@fitims Dolf is correct, the imp works together with the imp service. Very slow internet shouldn’t be an issue - the imp hardly uses any bandwidth - but if you have 5 seconds of latency then I’d almost hesitate to call it an internet connection :slight_smile:

We make the server reliance very clear on our website, on sparkfun, etc. Sorry that it doesn’t work for your application.