UK School teacher - hugely need your help

I am a humble English teacher in a UK highschool. I want to use the ORBneXt One for an exciting educational experiment.

We have tried EVERYTHING and can’t get blink up to work. I gave up using the school Wifi as it would say it was setting it up then after about ten minutes say it wasn’t successful. I was so desperate that I bought a wifi 3G dongle (Huawei E5330 )

Now I’m ever worse off than when I started! The Blink Up is stuck at “3” and says “connection to refused” - I turned off the Huawei E5330 Firewall and tried to add some ports by changing the settings print-screened below.

Would hugely appreciate any advice on how I can connect.

Thank you

With your school’s WiFi, did they give you an SSID and password to access the WiFi?

I’m thinking that your WiFi is “captive”, meaning you don’t know the password for the router, you have to view a webpage and enter a password to access the WiFi.

You cannot use an Imp on a “captive” WiFi system.

Also, in the U.S., the imp uses channels 1-11. Make sure your WiFi Router is not set above channel 11. Tell us how you connect to WiFi … directly, or through a web page?

I’d avoid messing with the firewall - it shouldn’t be necessary at all.

By the sounds of it, the app isn’t communicating with the Electric Imp Cloud, so it can’t get the data it needs to send to the OrbNext, ie. BlinkUp isn’t even happening yet.

Just to check, are you using the OrbNext app, or the Electric Imp app? The latter won’t working with the commercial OrbNext, only the OrbNext Dev Kit (it’s not clear from your post which of these you are using).

Hi thanks!

mseim: the IT department themselves tried and failed to get it to connect. I had a standard wireless password and can sign into the wifi on my cell phone directly with no further passwords. I should also say that I am able to connect as normal using my home wifi so there is no issue with the OrbNext.

Smittytone: I am using the Blink n Play Ignitor app listen on OrbNext’s own website.

The dongle I have just uses 3G and is independent from the school’s network

It works at home but not at school. So the problem appears to be only with the school’s WiFi router configuration (or firewall). Not sure where to go from here … smitty?

the 3g dongle doesn’t work at home or at school obviously but i feel like there’s some kind of setting i could change to make it allow it

Is the phone hosting the BlinkUp app also on the 3G dongle’s WiFi network? Might be worth making sure the phone is connecting some other way, to see if BlinkUp proceeds as expected (even if the OrbNext won’t then connect to the dongle).

You using an Android device or iOS?

Sorry if you’ve checked this, but is the 3G dongle actually connected to the 3G network? Looks like it has from the screen shot, though

PS. Have you got as well as Ignitor? I believe you need both.

Afraid so - my Android phone connects to the 3G just fine. And I can browse the web when I’m connected so I’m guessing all that is working. The dongle gives the option of a DMZ - I don’t really know what that is but is it something Blink up can use?
I will try and experiment more with the dongle settings
I do have both apps

My phone may have been getting internet from its own 3g data! The dongle wasn’t working after all! I will return it. Any advice on what to buy instead? I guess just a different dongle. This dongle was working with my PC but not my phone. I’m sorry for appearing so clueless - It is still an issue I need to resolve

You are on the right track with the dongle. I am doing a similar thing in one of our offices, and ended up with the same solution as you.

If the dongle you have is broken, I would just get a replacement. If the dongle is working but won’t allow blink up, I would get another brand. But I seriously doubt the brand makes any difference.

You don’t want a DMZ, you just want an SSID (network name) and password. The dongle we have had that preprogrammed and it was on the label on the bottom of the unit, we didn’t need to reconfigure anything at all)

Then ensure the dongle is working before we do anything else. When you get the new dongle, set it up and then connect your phone to dongle WIFI. Go through your mobile phone radio settings and TURN OFF your cellular radio but leave the WIFI ON (this will ensure that the phone is only getting data through the dongle and not its own 3G). Then use the phones browser to go someplace. If you can get to a web page through the dongle, then we are good to go.

At that point you should be able run the blink up application like it shows in the ORB video and it should connect.

Success is ahead!

I have same issue with super secure setting school wifi network.
Just use mhotspot generate another wifi.
This work for me good luck :slight_smile:

If I need an ad hoc WLAN for Imp use, I usually just use my phone as a WiFi hotspot. But you do have to watch for UK phones and dongles using 2.4GHz WiFi channels 12 and 13, which are inaccessible to a US-spec imp (or imp-based device). More info here.

Thank you!

After all that and just when I thought I’d made a breakthrough, still nothing. It now goes through the blinking and just says “connecting” forever. I am going to email the company who made the hotspot (TP-Link) but no idea what they could even do or say. It just isn’t logical. I can visit any website on my phone with the same wifi with data off.

We’ve used about 4 models of TP-Link with imps and they work just fine for us. TP-Link list the compatible 3g USB sticks on their website.

Just to be clear, you can confirm if the access point is working by following Hyperone’s instructions above. If your phone can’t get an Internet connection through the TP-Link unit, then the imp has no chance either

coverdriven, did you need to change an settings on your TP - Link before it worked? I have a TP link m5350 which works fine on my phone. I have turned off the phone’s own 3G and it definitely works.

One thing I haven’t mentioned… my ORBneXt is usually blue but every few minutes it randomly turns purple and the sensor flashes - no idea if that means anything (with or without blink up)

No, we didn’t need to change the firmware. That said, we did have some problems with an TP-Link eating too much mobile data, but it still permitted imps to connect to it.

OK, if you’ve confirmed that Android–>TP-Link works,
it would pay to also confirm that Imp–>Android works.
Can you switch off the TP-Link unit and enable your phone as an Wifi Hotspot? Set it up so your ssid/pw is exactly the same at that you had on the TP-Link. If your imp has been blinked-up properly, it should connect successfully through your phone.

If it doesn’t, it may indicate a mistake with your ssid/pw arrangement.

OK just tried that and it still did not connect. I’ve also tried connecting to someone else’s phone 3g via tethering and still no luck. Do you mean that you think I got my password wrong? I don’t think that’s the problem as I can log in fine elsewhere with this ssid and pw

If you entered the password incorrectly into the BlinkUp app during the imp’s config, it won’t connect to the network (stored password is wrong). I’ve been bitten by this myself.