New Imp - no Wifi - no matter what - SOLVED

I was so excited to get the imp.

Got it powered up via the Sparkfun breakout board.

Got it to flash orange.

Checked my router, made sure it’s only operating in B/G mode, 2.4 ghz, WEP encryption, even named the SSID imp.

Installed Blinkup on my iPhone, entered the SSID, and password.

I’ve tried everything, when Blinkup flashes, the imp stops, then quickly turns green for 1/2 second then goes to orange

I’ve even tried the battery, placed the imp right on top of the router.

Unless there’s something that I am overlooking, this is a huge disappointment after all the hoopla about this device.

Any suggestions I have not tried in the last 6 hours?..

The quick flash of green means the wifi details were successfully sent using blink-up, but now the IMP can’t make the wifi connection.

When I used WEP I had to put the password into blinkup in hex format. Here’s a link to convert a key to hex format

Easier to just use WPA PSK or WPA2 PSK on your access-point.

Thanks rocketfire, unfortunately I tried WPA PSK, WPA-Personal, AES, I tried it without any authentication too.
I even tried the WPS method.

The closet I get to green is in the WPS mode, but clicking the router WPS button does nothing.

Could always be a faulty imp; after blinkup (and seeing the green flash) the imp should then never be flashing amber, as it has received wifi settings at that point. There’s no need to set b/g mode, the imp is b/g/n.

On WPS: check your router manual. Sometimes the button is disabled (you can re-enable it in a control panel), sometimes you need to press and hold for a couple of seconds and a WPS light will start flashing.

Sounds like the best idea is to try another imp; PM me with your address.

I got a new imp from the electronic store today, the same problems. When I try the WPS method I get confirmation from my router that the device is connected but I don’t get a flashing green light on the imp. It flashing amber/red.

I made sure my router TCP port 31314 is open, I even assigned an IP address to the MAC address of the imp, (0ca69002b38), I’ve tried using my wife’s and my cellphones as hotspots to use, I’ve even got a 4G LTE router that I’ve used, it’s definitely something with these imps. The imp is reading Blinkup because it stops flashing when it’s receiving the Blinkup, then gives a short green light at the end to confirm it. This is frustrating to say the least.

Update: I found that I can ping the imp’s ip address and get a reply for about a minute after Blinkup was completed.

screenshot of pings, then no reply after. This demonstrates that Blinkup works, my router is obviously set up correctly, why does imp drop the connection??

In such a discussion about failing to get a WiFI connection, somebody usually asks if you are sure that your power supply can provide the peak current that the imp needs to make a WiFi connection (>250 mA). Starting a connection can cause a power droop which then causes the connection to fail, then people find a big capacitor or a better supply fixes the problem. Sorry if this is a red herring, but somebody had to say it.

Thanks DrJack, for the help.

No red herring, all suggestions are thoughtful.

I have tried two imps, both powered by the USB cable and a battery.

I used the USB off my iMac.

On your thoughts, I have now tried the imp being powered by the USB adaptor for my Raspberry Pi.

Still the same outcome but now I notice something different.

Before the imp would receive an IP address, I could ping it until the flashing stopped, then about 1 minute after the flashing stops I get Request timeout host is down as per the attached file.

Far too much work trying to solve this when the customer shouldn’t have to figure it out…

Being available on the network for a minute makes sense if it’s associating/DHCP’ing fine but DNS or the connection to the server is failing - it’ll be pingable but as it can’t reach the server.

Can you provide any information on the router in use?

Can you telnet to “” port 31314 from another machine on the network and get connected, or does that time out?

This is rather an unusual problem; it sounds rather like you are firewalled somehow, but the fact you see it on hotspots too is confusing as everything shouldn’t be firewalled. Where are you located?

I’ve even tried the battery, placed the imp right on top of the router.

In my experience, placing the imp too close to the router will cause issues. You may be able to get an initial connection, but would struggle to maintain it.

Make sure the imp is at least 3+ metres from your router.

Another suggestion is to set your phone up as a hotspot with the same ssid/pw as your router. Imps generally work really well in this configuration.

I have a Cisco DPC3825
Firewall is turned off

I live in Toronto
I tried telnet 3134 with no luck

See attached files.

Houston, we have lift off.

For some reason, I am now able to telnet to 31314

I don’t why it started working but now the imp takes less than 10 secs to establish a connection.

Nothing on this side was changed.

Telnet success!

Uhh that’s very strange. I can assure you we didn’t change anything on our side either!

Generally the imp should be connected in <2s especially if you’re in the US. It’s typically about 1.1s on our office network or at home for me.

Any more info on what can cause this? I’ve got a network in Cambodia. telnet imp.electricimp 31314 looks fine from my laptop (cmd screen goes blank for a while then reverts to command prompt). But none of my imps can connect to the network. Anyone have tips on further debugging?

In my experience, it’s because I’m trying to connect to a 5G network. I forget every time. It only works on 2.4G! There should be a larger notice about this please.

@jamesb what LED code is the device flashing? (and as @kitty says, check your laptop is on the exact same network/band that the imp is connecting to)

And you have to set the BlinkUp app on the PHONE to the SSID/password of the 2.4G network.