New Imp - no Wifi - no matter what - SOLVED

It would be really helpful if the setup page on the app specified this in bold. :slight_smile:

Unfortunately, iOS doesn’t let us know what channel the wifi is on, so we can’t tell if the pre-filled (current) network name is one the imp can connect to.

…though obviously, if you are blinking up an imp005, then that’s fine as it has dual-band wifi :slight_smile:

Thanks for the tip with the band. The internet connection there is very flakey, sometimes it’s fine and sometimes it’s slow. It took hours to download a new firmware update to the devices. I’m in a different country now, so it’s going to be difficult to monitor the blinkup light, but everything is working ok now the firmware updates have been pushed successfully. Thanks.

I mean just put a notice/warning on the app page where the wifi settings are entered, such as, “NOTE: Some imps support 2.4GHz only.” I think a lot of folks would have a better experience. As in this thread, it’s a typical issue that’s often overlooked. Just a suggestion! I love the imp, and hope it succeeds!! :slight_smile: I think just a few tweaks like this would really help. I also think a Visual Studio add-on would make it much more attractive, and I don’t think it would be very hard to do. Working in the online IDE is just not a long-term option.

Yes, understood that there are some things that could improve the experience and we have them on our to-do list.

I believe some people are already using VS to deal with the imp, you can certainly do this. Most serious developers use the command line tools & things like builder or sublime text to do their development.

btw, there are well over a million devices on impOS :slight_smile:

OK, I’m still having issues with imps connecting to Ubiquiti Nanostation M2 (2.4G only). I can telnet to the network, I can connect using my phone. Some imps connect to the network, and some don’t (they all work fine with other wifi routers - eg my phone tethering). Any ideas - has anyone got experience using the Nanostations? Something in the settings that would cause some imps to connect and others not?

Not with the nanostation, no, but we use ubiquiti stuff in our offices.

How close is the imp to the station? Too close can overload the receiver in the imp.

Usually about 500metres. So I don’t think it’s overload. it’s on farms, rssi about -80dBm for devices that successfully connect

-80 is low, but ok. There will be variation device to device… but when you’re low on signal the housing can make a big difference. If you bring a device that works and one that doesn’t to a range where they both work, what’s the difference in RSSI?

I’ll see if I can find an un-deployed device that doesn’t connect to do that comparison, thanks for the suggestion.

But I’m not sure it’s RSSI related. I’ve got other devices that connect fine at -90dBm, even down to -94 for some devices below the crop!

Will try to gather more information.

I think I know what part of the problem is. My Ubiquiti stations have country set to Australia (that’s where I am), and sometimes the WiFi channel is 12 or 13. But some of my imps are US and some are “rest of the world”. So the US ones are failing to connect. It looks like the imp country can only be set at the factory, so I’ll try and change the Ubiquiti frequency list

About 30% of Australian AP’s are on channels 12 or 13, the others are typically on channels 1 and 7. Also from my experience 99% of people don’t know the admin password for their AP’s so it can be a pain getting USA version onto the wifi, for me now it’s the international version or nothing.
BTW did you say your imps are 500m from the AP’s? That pretty good.

Yeah good to know. Will be making sure I specify international version from now on.
I’ve tested communications out to 2.6km, pretty surprised! The ubiquiti has 10dbi gain, and it was on a flat farm with nothing yet growing, still…