Impee not showing up in planner


#1

I just bought my first electric imp, connected to and was flashing green. I look under the impees tab, and see a 16 digit code (which I assume is my impee). When I go over to the planner I see a blue node which just says blank (perhaps this is my impee). I click the settings icon in the top right corner and I see my “Hello World” example code in the drop down menu, but it doesn’t do anything.

Can someone help me figure out what’s going on?


#2

Can you explain what you mean by it doesn’t do anything? What should your code be doing?

It’s possible you’ve run into an old (known) bug in our old/non-beta IDE. Basically, you need at least two code modules for things to work properly. I solve this by creating a second (empty) code module… I just call it “bug fix” and never look at it again.

We have the process documented in our Hello World! Guide :slight_smile:


#3

That’s the code I tried to load. I tried loading a second set of code, and that solved the issue, thanks.


#4

Problem: 10-6-2013 at 8pm et. I have april boards. when I powered up my imps tonight none of them showed up in the plan or under the impee tabs. This was working a few days ago.


#5

What’s the LED on the imp doing?


#6

blinks red when I plug it in and then goes to green as usual. This is happening on two imps btw


#7

Does the code you’ve written have an imp.configure() line in it? That’s what causes the imp to appear in the planner.


#8

there is no way for me to add code to the imp as its not showing up anywhere. I can’t see it in the impee’s tab or any where else. btw, I have tried to re-blink both of them which seems to work as the led blinks green.


#9

You can always edit the code for the imp; if you are using the new IDE they will show in there, and if not you use the “code” button at the top to access the code that the devices will run.

You won’t see logging if you access the device with this method, but you can definitely add the imp.configure line and click save, then unplug/plug the imp and it will appear.


#10

the devices are not show up there ether.


#11

one (maybe) helpful note. they where both in the planner but I had turned them off and deleted them from the plan. when I plug them back in n yesterday, ether came back. I had done this a couple of weeks ago without any problems.


#12

Errr, there’s no code listed in your code tab?

As I said, if you don’t have an imp.configure() line in the code, and you delete the imps from the planner, they won’t reappear.


#13

So how do I fix this? I done see them in the code. Tab ether


#14

Don’t see what in the code tab? The code tab lists all the code that your imps can possibly run. There will be code listed in there which your imps are running.

Whatever code they are running, it is missing the essential imp.configure() call which makes them appear in the planner. If you want them to appear, you have to add this call as I’ve said several times above.


#15

ok I would like to add this line but as I have said, I can not find the impee’s anywhere. They are not in the Impee’s tab, they are not in the new devices section of the code tab and they are not in the planner. When I power up the imp I get a green led as usual. I have re-blinked them. still no luck…


#16

…or, the imp is not getting to the imp.configure line due to a runtime error in the code.

As you’re having so much problem editing the code, I’ve deleted the link between your impees and the offending code(s), so it should now appear as blank. You’ll still need to find the issue your code is running into before it calls imp.configure, though.


#17

Well, I don’t know what happened but they are showing up now…


#18

thanks for the help.


#19

They will not be in the new devices section of the code tab because they are not new, they’re old.

Blinking them up does nothing, as they are already happily connecting and running the code they have been assigned. As I said, this code is NOT calling imp.configure so they do not appear in the planner.


#20

well, what ever you did solved the problem and I can see them in the planner/imppe and code tabs again. so thanks for that.