Impee no longer showing on planner


We got one of our April impees no longer showing on planner or impee list. The impee seems to be connected to the cloud (green led slowly blinking forever) and I can see it’s mac on my WIFI router.
It was showing on planner ok till I deleted it because I couldn’t run the code (pressing run wasn’t doing anything). Now it’s gone, any ideas ?

Can you try going to the code tab and reassigning it to the default (blank) firmware, the unplugging and replugging?

Since I don’t have this impee ID showing, I didn’t find a way to reassign unboundsq firmware so I did:

  1. Go to code, edit last installed firmware on that imp to only have the lines in imp.unboundsq blank firmware = still not shown
  2. Completely delete the last installed firmware from code = still now shown

Would sending the mac address from the imp to you shed more light ? I haven’t saved the impee ID so I’m not sure about that one.

I’m wondering if the issue here is that the ATSHA chip isn’t responding. That state is currently not indicated on the imp very well, the server will just silently drop the connection.

This is happening with just one April, right? ie, no imp card in that April will show up in the planner, but all the imp cards work in other Aprils?

Sadly I don’t have another April board to test on my location.

Email and we’ll get another to you; if this works then we’d like the old one back to investigate.

I have a similar problem with my Hannah. I could not update code, then I deletet the impee (Hannah). Reblinkt it and it does not show up in the planner again.

This happened to me to tonight, where it wouldn’t update the code, so i deleted it from the planner. I was successful and was able to re-blinkup the imp and it showed back up in the planner.

I brought Imp and April, Connected and commissioned. On planner it showed up and i assigned hello world program. On planner i deleted and later not able to find it back in planner. I deleted the code hello world and re-plugged back in. I still dint find my Node in the planner. How ever in the code, i see impee bound to imp.unboundsq. How do get my Imp node in the planner ? How do i assign some other program? I see Imp is blinking green every second.

By the way I connected Impee with mini USB connected to my Laptop.

@Miki - I see that you have two imp cards. Do they both blink green when they are plugged into Hannah? If green, try inserting and ejecting card and reinsert card.

@srinathv77 - Your imp was running previous code so I just set it up to upgrade to latest FW. Blinking green is a good sign :slight_smile: as it means it’s connected. Can you eject and reinsert the imp card and see if imp reappears in the planner? Try doing blinkup again if this doesn’t work.

Once the imp appears in the planner (it may show up as “unbound” in stead of “hannah”), you can assign another program to it by clicking on the slider in the upper right corner of the imp node and a dialogue box will appear.

@Nong - Before I read your answer I swapped the to imp cards. My Hannah showed up again and I can run and change code again. On the April board I can’t do anything, so I moved the problem. Both imps are flashing green 1 Hz.

Mine is still not showing up on the planner. Re-plugged, re blinkup, but no success.

@srinathv77 - Your experience may be symptomatic of a bug we are currently working on. We think we’ll have a work-around available in a short while. Will keep you posted. Thanks for getting back to me and for your patience.

No worries Nong. As long as we know where we are wrong…its good to know that…

Any rough estimate to get this bug fixed? In fact I din’t go to office today, (had DMV work for long hours and back home sitting in front of Imp ;-(

Unfortunately, no time frame on work-around but we’re trying really hard to get it out. If it doesn’t resolve issue for you, we’ll see what else we can do. Thanks.

You seem to have got the update now, still having problems?

@srinathv77 - Can you try removing & reinserting imp card and reblinkup? Let me know if imp appears on planner or not and also, if not appearing, do the lights continue to blink green. If imp card does not make appearance on planner after attempt but continues to blink green then we may have you try a beta iOS app built specifically to work-around this issue or, if you don’t have an iOS device, you will have to send your imp card in and I’ll ship a replacement card out to you. Thanks for your continued patience and assistance with this.

I removed and reinserted. I did reblink from my android nexus one phone.

After the above steps, I see same green blink every second. But its not appearing on the planner. But i see a entry in “impees” section, and upon clicking a link, it shows “Last connected: Fri Oct 05 2012 05:41:47 UTC”. And it is linked to imp.unboundsq program (which i see in ‘impees’ section. Upon clicking the edit code it goes to Code viewand i see ‘Run’ is enabled, if i click run, it simply show the waiting (circle gif) and nothing happens.

What ever i do its not appear on planner.

I tried re blinking from “HTC my touch” Android phone as well. Same results. After re blinking, i see imp is blinking green every second. But not showing on planner.

I do have Iphone 3. Does your app support iphone 3? Also I have Ipad as well.