Imp / Planner Not Acknowledging HTTP IN

My imps have been set up and running smoothly for months. However yesterday they suddenly stopped acknowledging HTTP input.

My code hasn’t changed and what’s strange is the COUNTER on my planner isn’t even incrementing even when I directly access my… URL (from a different network, too). I receive the OK response, but nothing happens in my logs and, as I mentioned, the COUNTER VIMP doesn’t increment (on any Imp). Tried creating standalone HTTP IN and COUNTER VIMPS and same story.

I even pulled a fresh new Imp out of the packaging to see if that resolved it, but no luck. Haven’t tried it with a new breakout, but may unpackage/setup an April tonight if I can’t figure it out.

I should also note that my data OUT COSM feeds have continued to operate properly and the device functions as expected when I send new code to it. It’s just my HTTP IN VImps!

Any ideas?

That’s strange, I just tried the same experiment (HTTP IN to COUNTER) and it works fine.

Try deleting the noodles and reconnecting?

Odd. Tried new noodles with no success. For what it’s worth, my SHOW INPUT aren’t recording a change, either.

They shouldn’t have changed, but can you check the HTTP IN URLs are still the same?

I’m having the same problem. I had an HTTP IN which had been working fine for months and suddenly stopped. I check the URL and it hadn’t changed, but I also deleted the HTTP IN and created another, updated my script and it’s still not working. The https request is getting a response off “OK” but the planner isn’t showing the updated value and the hardware isn’t getting the data.

Yeah, triple-checked the HTTP IN URLs and even created new ones. Again, they respond OK, but nothing outside of this indicates the response was processed or even received.

jrook - have PM’ed you for more detail

Ok, this is now resolved; we had some overly aggressive throttling in there (if an HTTP IN node was unconnected and hence couldn’t deliver its message, it’d throttle the whole plan for a while).

If anyone else sees issues, let us know!

Hugo, I can tell that everyone is on pins and needles anticipating the new agents. I’m sure you’re getting sick of people asking about it. Maybe it is a good time to update the expected reveal date. Coming late March … not very informative.

The new agents are going to blow the imp wide-open … it will be big!

This now appears resolved for me and I’m back up and running - thanks!

The issue appears to have somewhat resurfaced, at least with a specific Imp. Same exact details as last time. Only difference is, every once in a while an HTTP IN slips in and performs properly.

Same issue here. No HTTP IN working at all. Also output data logging through HTTP Request to my remote server not working. Planner does not show 200 status so I assume HTTP Request nodes are broken. Should mention that this was all working fine during testing last weekend or the the one before (can’t remember :slight_smile: ). Nothing has changed on my side. The imp was powered down for the week (or maybe 2). Fired it back up today and all HTTP I/O is non functional.

Deleted the imp from the planner and all associated nodes. Rebooted imp and added it back to the planner. Recreated the HTTP nodes and connections - No change - HTTP I/O still not working. The HTTP Request node doesn’t update its HTTP status code. I have a Web App that calls into the imp - the response code for that request is 200, but the planner does not seem to get the message.

I have the exact same problem as “deonsmt” here, http in node seems to not work, but yesterday everything was fine…

Same problem here, everything was working fine three hours ago, now there is no HTTP IN at all…

We did some more migration this morning, and it appears to have caused some issues. They should now be resolved.

Thanks for raising the flags when you encountered the problems!

Looks to be working well again. Thanks!

(Edit :slight_smile: ) HTTP In is working for me too. Remember to change the URL for the HTTP In node if you delete it from the planner and add a new one.

HTTP Request is also working

Anyone else having HTTP-in issues this morning?

My imp was working fine last night, but this morning (as early as 4:30am pacific) it is not responding to its HTTP-in 95% of the time. Tried several reboots. I have a watchdog status readout every 5 min that is working just fine.

System-wide, or just me?

Yes, I’ve experienced similar intermittent issues with one of my imps.

I’m still finding the HTTP API very unreliable - its currently returning “OK” when I make requests of it, but noting is showing up in the output I’ve got in the planner or the logs I’ve got from the IMP. I’ve tried rebooting the IMP but that doesn’t change anything.