Imp not showing up on IDE

Hello all,
I received my imp recently, and started to configure it today. I managed to get it on my network, and see it on the IDE, even tried to write the hello world application. Having seen the code failing (on the led <- hardware.pin9 ) line, I decided to remove the sketch and the imp from the IDE.

Later I tried to pair it again, but so far failing constantly. The imp first flashes with a fast green, then 3 reds, and eventually periodic greens. I also notice on my internal DNS server that it looks for host (DNS server is on a linux box). So apparently it gets the wi-fi setup correctly. I can also ping the IP it got assigned from the DHCP server (running on the same linux box as the DNS server). Btw, is the imp supposed to respond pings?

I tried this both on a Mac (with firefox and chrome) and windows (chrome) box.

Any ideas on how to troubleshoot will be greatly appreciated.

Are any devices listed in the IDE? How did you remove it?

There was one and I added a sketch to it. Then I first removed the sketch, and then the device from the settings dialog (gear icon) for both of them.

More details, imp is connected to the april board, powered through USB, connected to a USB port on the desktop computer. After turning it on, it flashes red first, once, and then green every second for about 30 times then flashing stops. During that time, I see an address resolution request for on the DNS server and an IP is assigned for the imp. Neither during the green flashes or after, I see anything on the IDE (yes I am refreshing, and trying in IE11, Chrome and Firefox).

Bit strange. I can see it connecting fine and running hello world code. Will file a bug…

Any way to resolve this Hugo? My shiny imp is collecting dust.

Do you have any active or inactive models in the IDE?

That is the problem , I do not see anything. It says.

There is nothing to see yet! Click on a device to start editing!

And attached is how the IDE looks. Am I missing something?

Really no idea how that could happen. Will email you to get more info.

Hi Hugo,

I am facing exactly similar problem. I had my device working with self test code from When I was playing with Active and Inactive models I happen to delete all my models. Net result I am now unable to see my device on IDE. However, my IMP device runs the “SelfTest” code whenever powered on through USB. BUT I can’t see my device. The screen is exactly like that of Ercenk. Can you please help or guide.

Could you give more detail as to how you deleted a model with a device assigned to it? We’ve tried to replicate that but can’t…

Hi, I am having same problem . I had old code running . But now It goes green for while and then nothing . It does not shows in IDE or stays green ? I got this imp last year . Any solution or firmware update for it ?

Can you define “goes green for a while”? It may be updating its firmware if you see short-long green flashes then solid green. Leave it if you see this, it should complete in a couple of minutes.

I got my IMP last week and got it connected to my network 4 times. Green LED flashes for a while and then turns off & stays off. Re-powering the IMP, amber and red LEDs for a few seconds and then off again - no more green… It seems to turn off after +/- 30s, is there any way to keep it on?

Green flashing for ~60s then turning off is normal. It got connected, and turns the LED off to save power and because flashing LEDs can be annoying.

If, when you re-power it, it’s not going green then it’s having an issue connecting. It should try for 60 seconds unless code is telling it otherwise.

What’s your mac address?

I am having a similar problem.
I have 2 Imps both seem to “Blink up” OK.

They go in to a quiescent state (no LEDs flashing) after power up and the “Getting IP address” blink state.

No devices appear in the IDE.

Mac addresses are:

I am running an Actiontec F2250 router

Android 4.4.4 legacy mode on a Nexus 7 for blinkup

Do they flash green at all? I don’t see the mac addresses in our logs, so I’m not sure they are actually configured at all.

There is sometimes a short green blink about the time that the Android device stops it’s blinkup blinking.

This is followed by the {Red-Yellow-Delay} sequence 16 times. The 16 Red-Yellow-Delay repeats 4 times. Between each of the 4 blink sets there’s a single Red blink

Then there is no blinking , I measure about 25 micro amps current draw in this mode. Periodicly the Imp will re-enter the 4 sets of 16 Red-Yellow-Delay mode.

Yes, I too am not sure they are configured at all

I’ve discovered the cause of the problem.
I had not entered my the WiFi access point password into the Android blinkup app.