Imp appears to connect, but does not show up in planner


I have a new imp and Sparkfun Breakout Board (

My understanding is that this breakout board can be powered and work (ID chip is built in).

I have commissioned my imp with the iOS app and it goes through it’s red and red/orange flashing before it quickly settles into it’s green blink (once per second).

However, the imp (impee within the BOBoard?) does not appear in the planner or list of impees.

I’ve tried to blink the config multiple times, even changed my password on my planner account to rule out problems with a strong password.

Any thoughts on how to fix this?

This bears the hallmarks of your router providing the wrong address for the upgrade server, due to a buggy DNS relay client; we added a workaround in later versions but that doesn’t help if it’s biting you right now.

Two options:

  1. Look in your router setup, and if you see a “DNS relay” setting, turn it off, save, and reboot the router. The imp should then upgrade. You can turn turn it back on again.

  2. Try it on another wifi network for the upgrade, then you should be fine from then onwards.

Hi Hugo; I am assisting with this issue.

I have the imp (and my laptop) connected to the router. I’m not sure what “DNS relay” refers to - there is no such explicit option in the router. If recursive DNS: yes, the router assigns itself as my DNS server via DHCP. I disabled this and used our upstream DNS server, with the same result.

I can take any troubleshooting steps you recommend. Thanks.

DNS relay is a local DNS cache. What we found was that many routers (likely sharing the same codebase) that offered DNS relay were incorrectly returning cached results where the DNS transaction ID matched - we were not randomizing this ID, but as the request was for a different CNAME the relay’s behavior was still wrong.

What router make/model?

It’s a Cisco E4200.

Hi Hugo. I’ll be trying this from home tonight as well. There I have an Airport Extreme (and a generally more typical setup).

I’m having the same issue; just got my Electric Imp and Breakout from Sparkfun today. It’s been blinking green for the last couple of hours.

I anticipated potential problems with my AT&T 2Wire router, so I got an Engenius router from my local Fry’s. No luck on either of them currently. I’ll attempt a connection at work tomorrow as well.

I will see what router options are available, and inform everyone of any progress.

Thanks for the help Hugo.

I’ve tried from home still without luck. I got the same results as at work and am seeing a blinking green light. Is there a way to confirm the error that the imp is seeing or if it is reaching the server?

Same issue. Tried turning off DNS relaying, switching routers, re-flashing settings a half dozen times. Imp and shield from SparkFun. Just sits there blinking green like it is connected, but nothing shows. Was going nuts trying to find it on the site before I realized others were having the same issue.

Sorry, can’t tell if this is an old thread since timestamps only show time and no date on posts.

This is not an old thread. Timestamps are all from today;)

Same board (Sparkfun Breakout Board), same day, same issue! I tried both my home router network and an open cellphone mobile hotspot. blinkup runs fine, the dhcp table shows the new device, but nothing shows up on the planner, and the slow green light blinks non-stop (does not stop after 60 seconds).

Same problem, just recieved it yesterday, did the blink up, had some trouble because my ipad was in full screen mode. It only does a slow green blink, my router has dd-wrt installed. Nothing showed up on the website.

A bit more testing. Tried open security on wifi, verified channel 11, disabled firewalls, cleared wifi settings than reloaded, unplugged for 20 minutes in hopes of draining any batteries.

Any way, wonder if it is only SparkFun peeps who are having the issue.

This is all very strange. Green blink = connected ok to server, so blinkup is working and the device is connecting ok.

Looking into the issue now to determine if it’s a server-side update that has caused the problem; certainly, users who already have devices are fine so it’s possibly only happening to new users. Stay tuned - there’s been a lot going on with the new dev environment behind the scenes.

Just got an IMP at the YC/Upverter Hackathon. Tried to connect it today - Same issue: Flashes steady green but does not show up in the planner.

Ok, the issue appears to be with upgrades, in that all your units are running an old firmware version (the factory-loaded one, which the server is requesting they upgrade). Though this exhibits itself in much the same way as the router bug, this one is server-side. We’ll get this diagnosed and fixed asap.

Note this only affects brand new imps that have attempted to connect on 2/27 PST.

Apologies for the bad out-of-box experience!

Thanks for the update. I look forward to trying when you let us know.

Same issue here with the APRIL breakout board, happy to see it is being addressed and I’m not insane… Well might still be insane :slight_smile:

The issue has been found and the fix should be live in the next 30 mins or so. The issue was narrowed down to early releases - ie, code on imps fresh from the factory - which couldn’t handle one of the more complex responses from the server.

Thanks for your patience, and please let us know in this thread when you’re up and running!

It is now working for me. Thanks.