Electric Imp and Budweiser Red Light

have you set your wifi channel below 12?

How would I go about doing that?

Check your wifi-router settings

On a mac. Can you suggest how I do that?

My router is linksys

If you’re in canada your router should not be able to be set to any channel higher than 11.

Thanks for the tip Hugo…saves me trying to figure that out!

After numerous (and I mean numerous) attempts to connect it…I finally got it connected with my iPad. Now, it flashes red, orange and then green. At first when I synced it on the app and it gives you the prompt to check the light, it didn’t work. So i shut it off, replugged back in the imp card and it worked.

After about 5 minutes or so, I tried again on the iPad to test the light and it didn’t do anything. I once again had to pull out the imp card, and then it flashed, orange, red and then green.

Is this normal, or is this an issue?

If it goes green, you that should mean that the Imp is connected properly. I don’t have a Red Light though, so I can’t comment on any of the other functionality.

The red light goes to sleep after a couple of minutes of no activity (unless one of your nominated teams is playing) so it’s normal that the test button won’t work after a few minutes.

As for the test button not working on the first attempt, this should be ok but also relies on servers outside imp’s control so I can’t give you much more info on that.

I have just opened up a new Budweiser Red light. When I turn on and insert the imp card it just flashes orange. Wifi is working will all other devices in the house. Really disappointing. Any suggestions would be greatly appreciated.

You need to follow whatever instructions come with the Red Light for “Blink-Up”. This is the one time process for telling your Red Light what your WiFi information is.

Yes that is exactly what I did. It doesn’t turn green as it should. Tried multiple times.

Make sure your WiFi channel is set below 12 in your router

What if it is set to auto? is that ok? I will change anyway.

only if your location is set to be in the U.S., but that might not be the case at this moment

Try taking it to a neighbors house and blinkup to their wifi. Eliminate or determine if it’s your router.

…and what phone are you using for blinkup? If it’s a samsung then ensure you’ve turned power save mode OFF and turned brightness up to max.

I was able to get the blink up to go after removing the case from my ipod. Put the screen right against the card. All connected up now. Only problem now is I have a 10-15 second delay for when the light goes off after a goal. Not sure how to fix that one…

The latest version of the app has a “add delay” function. It only goes to 10 seconds though.

my app won’t connect. I get the green flashing light to indicate online but the app times out in step 4. Seems other have the same problems and no answers on here. I don’t need a delay. The light goes off too late not too soon.