Electric Imp and Budweiser Red Light

Hello. I purchased a Budweiser Red Light and it uses the Electric Imp card to receive signals from my home network. I have not been able to get it to connect to the network using the Budweiser Red Light app. I have tried it with my normal settings on my router (WPA-Personal) and then with no security settings. It still will not connect to my home network. Do you have any suggestions? Thanks.

Got any detail on what your router is? What phone are you using to configure?

I am using an iPhone 5 and the router is a D-Link DAP-1360. My friend just tried it on his network and it connected fine so I am thinking it must be something I have set on my router that is preventing connection. Using the Bud Light app, I am getting the yellow-red-blank light combination after running it. The same friend tried to conenct using his phone (an iPhone 4) on my network and the same error occurred here so I am leaning towards something on my router that is stopping the connection.

Is there a preferred security mode to use? WPA vs WPA2? TKIP vs AES cypher mode?

No preferred security mode, no - I mean, you really ought to be using WPA2 as it’s more secure than WPA. In general, this means you use WPA2-AES.

The DAP-1360 appears to just be an AP; what is your router (ie the box between your internet connection and your local network)?

The DAP-1360 can act as a router as well. It is what I am using for my home network in Ethernet to Wireless mode.

The modem is a SMC Networks SMCD3GN. But I am just using that to connect to the internet.

Getting closer I think…I disconnected the DAP-1360 and just used the SMC Networks modem as it can act as a router as well. Same results…

Contacted my friend who I did have success connecting the light to his network…he doesn’t have this modem, he has the older one that our telcom company up here offers. Mine was an upgrade to get a different internet package - and I use upgrade as a loose term because it is horrible. I think this is modem related…and if it is, I may have to send the light back.

Have emailed you to get more info…

For those (like me) like wondering what a “red light” is, it’s a red lamp that flashes when your city’s hockey team scores.


I too am having issues connecting my Budweiser Red Light to my wifi network through my router. My router is a Linksys model WRT54GP2 and I’m using the app for iPhone 4. I’ve tried going through the official trouble shooting guide (of little help) with no success. I’m almost certain that issue lies within the settings of the router. Any thoughts?

Have you looked here?

I’m also having issues, I’ve tried 2 different phones a tablet and my computer, and I’ve also tried 2 different WiFi connections from 2 different companies and both gave me the same results, it goes through blinks a green blink what appears to be slowly and says on the app that it could not connect, any ideas on what else I can try?

According to that LED chart it appears as though it flashes green once the blink-up is complete but before and after it is flashing orange and red. As I’m certain the wifi password is correct, this would indicate a firewall. Perhaps my question is more about a work-around for my specific router.

So I should be looking for a firewall fix? Or a way to turn it off on my router to test it?

I’ve actually tried renaming my network and I thought this appeared to have solved the problem (the LED is now flashing green after the blink up), however, the app is still saying “Time out Your red light could not connect”. I’m stumped.

I’m not sure bizzy. According to the LED chart the process seems to have worked. I’m just not getting confirmation from the app itself.

I’m having the same issue I’ve tried friends houses with WiFi from a different company too… It looks good but the app says otherwise

I have the same issue, budweiser is sending me a new card. See if that works. I tried 2 different routers and nothing works. Flashes green and then step 4 times out

Hi, after hours of frustration I have solved my issue. I used an iPad to flash my card. It blinked green but I got the step 4 timeout. My router recognized the red light as a client. So…
It’s the routers fault! I switched my dir 615 for an asus rt ac 66u and its works immediately! It seems to have same settings, but I would suggest changing unicast option . Good luck!

Hi all,

I just received my Budweiser red light today, and I am unable to get it to sync to my wifi network. It’s continuing to time out and just flash the red/orange lights.

Is this a problem with my imp card?