Coffee Time with my Imp

I mentioned a few days ago we were putting an imp in a coffee maker so you can brew a pot from anywhere in the world. This is a simple project and worked great! We are cleaning up the pictures and the code then I will post them here. In the mean time here is a short video of it in action.

Very nice!  I’d like mine with cream, please :slight_smile:

Thanks Zanderx!

But but where’s the shot of the imp? Is it inside?

Yes Yes,

Nice glamour shot! :slight_smile:


Any chance you can share your connection code and how you connected the imp to the On/Off switch?

Yes sorry, been a busy few weeks and haven’t been able to really do anything outside work. Coming up!

Here is the code and post

Thanks for sharing the details Matt.

Anytime! Again sorry it took forever, We are working on a garage door opener and a guitar recording stomp box that sends the recordings to a web server Via the IMP.

That sounds awesome!  Looking forward to it!

Thanks. Nice job in explaining every aspect of the project.

Can you explain in a little more detail how you wired the USB cable and how the wires come off the “On/Off switch of the coffee maker to the April Electric Imp board via the 3.3v pin and the #8 pin”.? I just do not want to fry my April!

I know this must seem like a lame question to a hardware person but I want to learn how to hookup actual AC voltage items to an imp such as April.I do have a pretty good understanding of the software but want to get a better grip on the hardware end.

What is the best way so that the method post would return to the input page opposed to just directing to the page where it would say “OK” and then you would have to go back a page.

Based on your idea, me and a friend made a simple LED dimmer, using a JavaScript website. It has a ON/OFF button and a scroll bar to control light intensity. The program works fine, so does the website. However, maybe we’re sending to much post requests when dimming the light, because after some uses , the imp goes offline (it varies, we’ve had 1 hour playing with the controls to 5 minutes, and in both cases, after a while we can’t communicate with the imp, only resetting the power supply).

I was wondering if anyone has had the same sort of problems.

Might be the posts (this stuff will improve with agents) but it also could be that the imp is input only and the router is timing out the connection when there’s no traffic.

Have you tried sending something periodically from the imp end?

But that’s not the case. We left it connected during the night, when we came back in the morning it was still on, it accepted a few commands but then it stopped at a given state and wasn’t able to receive any commands whatsoever.

Ok, so it sounds like it was the posts. As I said, this will improve with agents as they’re far more lightweight.

where can we find more info on the ‘agent’ concept ? Haven’t looked around in the forum yet…