Budweiser red light


#21

I’ve got the same thing going on. Mine will connect green and I can even test it for about 30 seconds but after that it starts flashing red and then finally just goes to sleep. Super frustrating.


#22

@b1llvance it’s normal behavior for the light to sleep after 30 seconds and the test button not to work any more (until you turn it off and on again). The device sleeps most of the time, waking up for scheduled games of the cities you support. It’s not intended to be a remote control horn…

@fatbomb have you asked Budweiser support? The backend service that the lights connect to is not run by electric imp, so we can’t help with that. If you give me the MAC address of the device I can look for anything unusual though.


#23

No it goes red then goes to sleep. So it disconnects after about 30 seconds of being connected then tries to reconnect fails to do so then goes to sleep.


#24

You said you can test it for about 30 seconds; as in, the test button in the app works, or it doesn’t?

Same question, if you have your mac address we can take a look.


#25

I just received a new bud red light and it appears to connect to the wifi because I get a green light. But the app reports that it failed. Failed to pair I assume. I’ve reset and tried again. every time i get a green light but the phone says no go, try again. I checked 2.4 ghz, iphone up to date and connected to same network, batteries new. Frustrating.


#26

What’s the mac address on it? I can check that it left the budweiser factory with the correct setup etc


#27

How do I register my device on the app, my app says register click below but when I try to click it it does nothing?


#28

I’m afraid I’ve no idea about how the app works. Last time I looked there was a “pair your device” button, I think. The budweiser red light website has instructions?


#29

Hey Hugo, it’s weird but I received my Red Light today also and it’s connecting to the Wifi (it’s blinking green) but the app just failed at the last step… My MAC is 0c:2a:69:0b:44:36

One weird thing, I did some wireshark traces to see if something was failing because of my router / firewall and I saw the light connecting on port 31314 but then, when the apps is saying “Connecting…” it just failed but the light is flashing green…

In the wireshark traces, i’m seeing some “Certificate error, Alert” from the server to the Red Light iPhone App…

Can it be related to a bad app update or a bad certificate on the server side?

Hope you can help on this…


#30

The exact error is: TLSv1.2 Alert (Level: Fatal, Description: Certificate Unknown) (Code 46) (from the server, I think they are Amazon hosted) toward the iphone IP, so pretty sure the communication of the app is broken…


#31

mac address is 02 2a 69 0b 4b 17


#32

Kevinthegreat I think we are having the same issue, pretty pissed also, but while Hugo can check our devices, i’m pretty sure something is wrong on the budlight servers… On my side, pretty sure you have the same behavior, everything is correct (light flash green after I done the config) but at stage 4/4 (Connecting) it just failed… I know my light is connected, but the apps is not able to sync with it…

Anyway, maybe it will be fixed soon, or we have to call budweiser (not sure how easy it will be to have support from them…)


#33

Thanks SpOuK3. I tried calling number and I just got a recording that directed me to the website and the website just had the same instructions that came with the light. I’ll check back to see if you post something after talking to “Bud”


#34

I think we have to call during the day (and they are Central time…) I just post on their facebook page (private message) will see…


#35

@Kevinthegreat Mine is working this morning, was able to complete the sync and test the light!


#36

Another quick update, budweiser acknowledge the issue with the servers… I received a messages they are working on it, since when I don’t know but like I said, for me it’s fixed since this morning… Looks like I was right on the certificate issue… Hope that helped others! Cheers!


#37

Yes, it looks like that maybe there’s an issue with the Bud app.

The imp is connecting and working fine (green light) but the app is not. We were not involved in the app in any way, so can’t help there but the guys who did make this are aware of the issue.

I’d expect an app update at some point soon…


#38

@Hugo I think they fixed this server side… It’s working fine since this morning! And, since I message Budweiser on Facebook, they got back to me earlier today saying that they were working on the issue. Anyway, issue solved I think :slight_smile:


#39

Hey look at that! It works!
Thanks guys!


#40

I have a new goal lamp. Hooked up and ready to go. It has gone to sleep. Is it supposed to wake up at game time if I have 5 min warning on? Do I need to have the App on and in same room?