Budweiser Red Light

Just received a Bud Red lIght as a birthday present (thanks kids) but can’t get it to connect. The Imp card just flashes orange, doesn’t flash red at all then goes blank after 60 seconds. Have used an Iphone & Android phone but neither works & have even tried installing new batteries.

Any ideas? Thanks.

Does the imp flash green briefly at the end of the blinkup?

No, it just goes blank!

Ok, sounds like it’s not getting the blinkup. Turn the red light off first, get the phone ready (iOS preferred), turn the red light on so the imp starts flashing, then press start on the bud app and hold the iOS screen right against the back of the imp card - don’t hold it, as in the diagram on the phone - against the red test button! Also, try not to do this in a bright area (like, don’t do it in sunlight).

Keep it still during the ~10 seconds and just as it finishes, you should see a short green flash from the imp, then it should connect. If you don’t see the green flash then the imp didn’t “hear” the phone’s signal.

I just tried setting up my new red light and am having difficulties.
When I go through the set up on the iOS app the lights blink red and orange then three green flashes then it stops blinking and the app times out while trying to connect to the light.
I have re-flashed a couple of times all with the same result. Any suggestions?

Got the mac address of the card?


@seattlefan tracked down your imp; it looks like your red light has a hardware problem, or the imp is not fully seated in the socket. Try removing and re-inserting (until it clicks) and blinking up again - if it still doesn’t work then you need to contact budweiser.

Thanks! I reseated it several times with the same result. I’ll give them a call.

I have tried many times with an iPhone (set for max screen brightness) in a blacked out room (at night) & holding the phone right against the imp card, still no luck. The Bud Red Light usually only flashes orange & then stops flashing completely. Occasionally, after trying to blinkup when the app is “checking to see if you’re red light is on line”, the imp card will flash red about 4 times then continue flashing orange before it goes blank. I have yet to see a green light!

That’s very unusual for an iPhone. Does the card stop flashing during blinkup? If it doesn’t then maybe the imp card is faulty.

I got a red light for my son’s birthday and followed the hole process and it seems to be connected to my WiFi (checed the Mac address connection on my router) also pinged it and set up a reserved IP for it.

My issue is after setting it up the light never went off even after 2 or 3 goals. I must have set 10 teams up and nothing. When I sent it up with the blinkup I never got a confirmation of the connection on the iphone or my S4 phone.

Is there a way I can check the settings on the IMP via http or some other way? Also is there a way to test the connection without the phone?

Lastly I just got a new provider Bell and the router is working on subnet but my main router is a Linksys E4200 and it is on subnet

I’m just wondering if this could be an issue? I have many other networked devices and they all work fine (PS3, Wii, Wii-U, Xbox, smartphones etc.). Not sure how the device gets its signal for a goal? Is it polling or does it have some sort of HTTP server on it that gets hit when the goal light needs to go off? I am curious since if this thing doesn’t work I think I will send it back.

If you can give a bit more info (like the mac address on the imp) then we can look into it. Does the imp flash green after you’ve configured it?

The imp makes an outbound TCP connection to the imp servers, where an agent runs which integrates with the Budweiser servers that provide the sports data. You shouldn’t need to do anything special - if the light flashes green then the imp is happy and should get goals.

We have been trying to connect our new Budweiser red light and have yet to get any connection or even a green light. Is there anything I can try? I have tried a lot of the suggestions!

What phone are you using to blinkup?

a iphone 4

and we tried with our ipad 1 as well with no luck

We’ve had reports of iOS7 having issues with older devices - some options are to stop all background tasks and reboot the phone, then retry.

Alternatively, try with the iPad 1 but at “1x” (ie do not expand the phone app to fill the screen). iPads should work fine, but the original iPad was a bit underpowered.

i hadn’t updated my phone to the new update and it didn’t work, so I updated the iphone and still no luck

thanks for your help I was able to get the light to work on the ipad!!!