Trouble accessing some of the git libraries in the IDE


#1

#require “AWSRequestV4.class.nut:1.0.2”
#require "AWSLambda.class.nut:1.0.0"

no such public library awslambda.class.nut

#require "HTS221.device.lib.nut:2.0.0"

no such public library hts221.device.lib.nut


#2

Hmm, flagging this up, Possibly the latest versions weren’t pushed (these are ones with recent updates).


#3

Both #require “AWSLambda.agent.lib.nut:1.0.0” and #require “HTS221.device.lib.nut:2.0.0” should be available. Please double-check.

Both libraries were pending because of the internal review. Documentation will be published at the Dev Center shortly. Meanwhile please refer to GitHub: https://github.com/electricimp/AWSLambda and https://github.com/electricimp/HTS221 for more details.