Tmp36 Flaky

I have my imp hooked up to my garage door and also have it reading and streaming data from a tmp36 sensor. It has worked fine forever, but lately it’s been reporting back “bad” data.

I’m reading the temperature every minute, you can see below the bad values coming back, then next sample it goes back to correct temperature. I’ve checked all my connections and everything seems fine. I’ve even rewired the whole thing with the same results. Below you can see the bad samples.

I’ve even checked the supply voltage and it is fine and consistent.

Anyone else ever see this?

Do the TMP36 ever go bad? (It’s been running for years).

2015-09-04 18:11:06 UTC-7 [Device] temp new calc: 79.6276
2015-09-04 18:12:06 UTC-7 [Device] temp new calc: 79.9397
2015-09-04 18:13:06 UTC-7 [Device] temp new calc: 80.0844
2015-09-04 18:14:07 UTC-7 [Device] temp new calc: 80.0844
2015-09-04 18:15:07 UTC-7 [Device] temp new calc: 80.2898
2015-09-04 18:16:08 UTC-7 [Device] temp new calc: 28.07068
2015-09-04 18:17:08 UTC-7 [Device] temp new calc: 28.3599

2015-09-04 18:18:09 UTC-7 [Device] temp new calc: 80.2898
2015-09-04 18:19:09 UTC-7 [Device] temp new calc: 80.1452
2015-09-04 18:20:10 UTC-7 [Device] temp new calc: 79.9397
2015-09-04 18:21:11 UTC-7 [Device] temp new calc: 79.8593
2015-09-04 18:22:11 UTC-7 [Device] temp new calc: 79.3385
2015-09-04 18:23:12 UTC-7 [Device] temp new calc: 20.6947
2015-09-04 18:24:12 UTC-7 [Device] temp new calc: 79.8559
2015-09-04 18:25:12 UTC-7 [Device] temp new calc: 79.5667

Is it an imp001? I have had the same problem, but that turned out to be the card holder having a bad connection.

Mine is on my garage door too, and I suspect the cheap one I used corroded on the connectors.

Yes. imp001. Were you able to fix the bad connection? Something you can see?

Which pin are you using on imp001? Pin1 is the one that was known to have issues with a subset of cards. If so, try a different pin first to see if it’s happier then?

In my case, I switched the connector to the same model as on the April board, solved the problem for me.

Hugo, I’m using Pin1. I’ll try switching, but it’s all soldered up at this point.

It’s likely that; you can try putting a sticker on top of the imp card (to apply downward pressure on the contacts) - that might help. If you contact us we can send a replacement card, too.

So imp ID is socket based and not card based right? (Meaning code is downloaded based on iD from socket?) I have another imp, I could stick that card in my “garage door” socket and see if it starts working right? Then if that’s the case, I could swap it out with you guys.

Yep, just put the card in. If it’s blinked up to the same account it’ll “just work”.

Hugo, That was the problem. Switching cards cleared up the issue. Is there someone I can contact to get a replacement card?

Yep, email with your mailing details.