Squinter 2.0.122 released


#1

Now out of beta and available via the Squinter > Check for Updates… menu item.

Because of server changes at Electric Imp, if you’re running a version pre-beta 13 (ie. any 1.0 version, or 2.0.121b12 or under), then you’ll need to update manually — download the latest version here.

Release notes here.

Users, please report bugs and other issues here.

Thanks!


#2

Squinter keeps on crashing after startup after I enabled auto login as well as auto download of products and devices. Impossible to change preferences and save them before it crashes…
How can I reset the preferences to default . I already tried deleting the Squinter entry in ‘Applications’ and reinstalling it, bu the preferences are remained…


#3

in the meantime I managed to be really quick and disabled the auto-loading before it crashed the app.
Going further, downloading a product seems to work well, as well as getting and selecting a device group.
It goes wrong when trying to update the associated devices in the device group. Then the whole app crashes.

Strangely enough, this worked well before the auto- migration of remaining models in the old IDE happened about a week ago. Can this be related ? (I didn’t select one of the auto-migrated models/products to be clear).


#4

Delete the preferences file in your Library folder:

~/Library/Preferences/com.bps.Squinter.plist

#5

The migration could be the cause. I manually migrated all my models a while back, so I’m not seeing this myself, but IIRC the migrated models are given modified names, and this may be what’s throwing the code. If you can grab a macOS crash report when it happens, and send it here, I can have a closer look and hopefully prepare a fix.