Something is broken still

My code is supposed to turn a light on after dusk and off at midnight (among other things). It stopped working reliably (last night, it was still on at 1:30am). I have an api setup to manually control it as well - this was not functioning though I go the usual OK back. I had to log in to the planner (which is still slow) and rerun the code.

I just checked the planner, and it displays my startup message on the block, not the code which should be displayed almost immediately after (the status of the relays). Something is wrong.

Finally, when I try adding an additional output (I have a bunch) and the code tries to set it, the application crashes. Am I running out of resources? any way to check?

It’d be good to see your code, and get your mac address so we can look up the status.

Can you PM?

Hugo, I sent you a PM with the account credentials so you could look at the code. I haven’t heard back.

Also, the application just stopped working as of 2 days ago. You can see the data logged on cosm was consistent up until 2 days ago. It also failed to turn on my backyard lights last night (so I noticed). Why would this be?

also, this is the last entry in the log file:

Sunday, January 06, 2013 23:25:29: temp=52.142 hum=73.08251 rssi=-76
Sunday, January 06, 2013 23:26:34: temp=52.106 hum=73.07854 rssi=-73
Sunday, January 06, 2013 23:27:31: Power state: online=>offline

It should log an entry each minute. What made it go offline? Hitting the play button in the application does nothing. I’m off to go hard-power-cycle it.
… It had no light on, unplugging it and plugging it in seemed to have fixed it. It has had a very good uptime up until just recently. I would assume this type of behavior is not desirable for an “appliance” – any way to debug it to help ensure it doesn’t happen again?


One other comment; I used to have a few additional outputports that wen set, would cause the imp to crash with an out of memory error. I just uncommented it, and it seems to work now - so I would assume some server-side bug was fixed (?)

Bugs are continually being fixed, so that’s very likely :slight_smile:

We’re looking into some reconnect issues now, I’ll update the thread when we find the root cause.

It could have been the memory issue; seemed your latest firmware freed up more memory. Though the app doesn’t run for more than a few hours without putting the device into permanent sleep. Any way to revert to an older version of the firmware (which worked)?

Currently there’s no way to downgrade software from your end, no - sorry.