Simple Input not working, what on earth am I missing?

I am struggling to do some simple stuff.

I am not receiving simple inputs, so I create a simple test program, and no matter what I input (via the planner), I get nothing.  Why doesn’t this work?

class myInput extends InputPort
    name = “My Input”;
    type = “number”;
    function set(number)
    {"Got " + number “”);
        server.log(“Received my input”);

server.log(“Awaiting input”);“Awaiting input”);

imp.configure(“Simple Input”, [ myInput() ], []);

I originally had this connected to an HTTP In with no luck, but now I have it connected to Tick Tock, and I get nothing. 


Oh, in case it is related. Even though I am “editing” the code properly (I see the live log), I have to hard reset my IMP to get new code to load.  The “run code” button doesn’t really do the trick.  Maybe I am not getting the concept of how a program should be structured (and I have looked at the examples).

In the planner view, click on the little slider for the impee and select "Edit ", when you’re editing that code, you should be able to reload the code using the run button.

I saw nothing wrong with your code, so I loaded it up and connected TickTock to it, and sure enough - it worked fine. You are connecting TickTock to it in the planner view, right?
Yep, they are connected. And my IMP says "Awaiting Input", and Tick-Tok is ticking 0,1,0,1.  I would have expected the IMP to say "Got 1", "Got 0", etc.  

Also, using "Edit test", and I am seeing "test" code. And I see the log:

August 27, 2012 7:26:47 AM EDT: Awaiting input

But hitting the run button doesn't print that log again (as expected).  Resetting the power on my imp makes it print a new "Awaiting input" log (new timestamp)


Ok, I posted a video of what things look like from my perspective.  I can’t imagine there is a hardware issue (although who knows, I did did a piss-poor soldering job, putting a header on my April board), as I can generally do  other things with the IMP, including, UART, etc.

The video can be watched from here.  So I am guessing it is something I am doing, or maybe some other commissioning issue that is making my imp un-reachable somehow (although it can load new software, so who knows).

Not sure if its a cut and paste artifact, but there’s a spare pair of double quotes at the end of the

Yeah, I took what was in my code, paired it down to be as simple as possible, so I could better debug. Removing that doesn’t do anything. Logging first thing in set, doesn’t log (so I don’t think it is being called).  I even changed the argument name (number) to something else, in case it is a keyword issue.

What else can I do to try this?

Also, I was hoping there was a way I could order another IMP and April card, since I have a project I want to be able to debug/work-on remotely, which is different from my current project, so having two would be nice (I only ordered one of each), maybe if I can get another one, at least I could know if there is something wrong with the ones I have now…Is that possible?

Hi - It’s really great to see folks incorporating our stuff in their projects - especially this early - but due to the demand and limited supply of imps and dev boards at the moment (there’s quite a long list of folks waiting to order), we really have to limit the number of imps and dev boards each person can get.  We are working very hard to get the next batch of imps and dev boards through production and out to the market.  At the moment, no exact time yet but I’d venture within a few months.

In the meantime, we’ll do whatever we can to help you resolve problems you run across and if does turn out that you got a bad imp, we’ll be glad to do a swap.




Thanks. I figured that might be the case, but figured since I didn’t order my limit (stupid me), maybe there was a chance.

Ok, so anyone else have any ideas?  Hard to do much without external input (well, one of my other projects is just reading data, so I guess I can just pursue that one for now…

Have you tried deleting the node from the planner, then removing/reinserting the imp so it comes back, then hooking it up again to the ticktock? I’ve seen transient issues that have been cleared by this in the past, though I believe they were fixed.

Well I did that. Now I get 3 slow green blinks, 12 fast red blinks (repeat) on my imp.  The planner no longer shows my imp…I can run BlinkUP, and the flashing stops while running BlinkUp, but then goes back to the same pattern. Bummer.

So, am I dead in the water here? Seems my IMP is foo-bared…

Hi cnr1089 - Please contact me at Thanks!

That pattern implies the code is crashing and rebooting, not that there’s a problem with the imp. Please assign the “imp.unboundsq” code to the imp, unplug and replug and see if it stays flashing green (and appears on the planner).

(you will need to do this from the impees tab, as you said the imp isn’t appearing in the planner)

Actually, that is exactly what I did, before removing it from the planner.

Nothing shows under impees anymore.

That sounds strange; can you re-blinkup the imp?

When I run blinkup, it clearly sees it (the lights stop flashing), but when it stops, it goes back to the same pattern. This is with the iOS blinkup app (I originally blinked-it-up with a friend’s android phone.  I have tried about 20 times.  I am wondering if maybe I pulled the plug when it was in the middle of an update or something. 

The imp is robust against interrupted updates; have you tried in another impee? If the impee had an issue (eg, ID chip not responding) then you might see behavior like this.

Not sure if my terms are correct…  If the “April” board I have is an impee, and the SD card-like thing is an imp, then I only have one of each, so I cannot try another.

Is there an easy way to determine if the id chip is working (can I attach onto a pin and check something)?

Hmm, look for traffic on pin 6 of the SD card at powerup?