Server.log gaps & imp.rssi - no values

I have an imp that wakes every 10sec & records it's RSSI.
I keep getting 4 consecutive readings at the same time stamp (not 10s apart)
where there is a gap in logs of between 1 and 4 minuets & where the RSSI value is 0.
Where most of the time it around -80/92 dBm 
28 August 2012 09:30:21: wake event: 3.185 _Mins:431 Signal: -92 dBm
28 August 2012 09:30:31: wake event: 3.181 _Mins:432 Signal: -92 dBm
28 August 2012 09:34:50: wake event: 3.185 _Mins:440 Signal: 0 dBm
28 August 2012 09:34:50: wake event: 3.185 _Mins:441 Signal: 0 dBm
28 August 2012 09:34:50: wake event: 3.187 _Mins:442 Signal: 0 dBm
28 August 2012 09:34:50: wake event: 3.187 _Mins:443 Signal: 0 dBm
28 August 2012 09:34:54: wake event: 3.157 _Mins:445 Signal: -85 dBm
28 August 2012 09:35:04: wake event: 3.191 _Mins:446 Signal: -83 dBm
28 August 2012 09:35:15: wake event: 3.195 _Mins:447 Signal: -84 dBm

Can you replicate this easily? The timestamp is added at the server end, which implies the data was buffered. What were the LEDs on the card doing at the time?

Hugo, I can’t get this to repeat but some observations

I was doing some wifi range testing seeing how imp fared though 2ft of Cornish Granite :slight_smile:
Move imp out of wifi range (27+ ft from MIFI)
- server.log stops but imp Green LED still flashes
- IDE & Planner think imp is still connected
- after a period imp LED flashed Red
- imp LED extinguishes
Move imp in to wifi range
- after aprox   8 mins IDE & Planner agree imp is Offline
- after aprox 10 mins imp reconnects & server.log begins
Difference today is imp does a full restart but yesterday it didn’t!

Any chance of getting signal strength reading on the mobile App’s?

Dropped wifi will indicate offline on the device more quickly in the future; the work for the server to notice imps being offline is in progress now but won’t be instant (there’s no way to tell unless data flows).

The LED goes out after a minute of attempted connection to preserve battery. It sleeps for 9 minutes then tries for another minute, cycling until it gets reconnected. This 1/9 minute cycle is currently preset but will be settable from imp code.

Note also mifi’s are fairly weak as AP’s. you’ll get much better range with a decent MIMO base station!

Please help understand where and what interface can be used to change the 1/ minute preset cycle. I am looking through the documentation but could not locate that. Any help/pointer on that front will be deeply appreciated.

Thank You

There’s no way to change the 1/9 minute cycle right now. We’re currently working on the “running with wifi disabled” implementation which will give you much better control over what happens when wifi goes away.