Problems with 'Janice'. Only a few triacs can turn on my solenoid valve

I got 5 pieces of the Janice reference design fabricated, components mounted and everything by ITEAD Studio (

I did not make any changes to the schematics or board layout except for adding a little logo :-).

For some reason i am not able to switch my 24VAC solenoid valve on and off. Without the valve connected and with the triacs on (blue LEDs are glowing) I measure 24,7V between ‘C’ and the respective activated terminals 1,2,3,4,5,6,7,8.

When I connect the valve between ‘C’ and one of the activated terminals, voltage on that terminal drops to zero, and the valve does NOT ‘click’ open .

I tested all five of the boards, on 3 of the boards one specific triac is able to click the valve open without problems. On one board channel 5 works, on another board channel 6 and on a last board channel 7 works with the valve.
On the two last boards none of the channels can open the solenoid valve.
Some of the channels seems to ‘half-open’ the valve for a short time like gives of half a ‘click’).

It somehow seems like the triacs are not able to supply enough current to the valve, but the valve should only draw 75mA in holding and 90mA rush. The MAC97A6 should be able to handle this right?
It puzzles me that some of the channels on some of the boards are able to drive the valve.

I removed the code from the example firmware that has to do with the RTC.

Am I missing something obvious here?
Ideas for troubleshooting/bug finding?

I have attached pictures of (I get error when trying to attach files right now, so see dropbox links):


And a Janice

Best regards

So in order to confirm that the Janice board could actually deliver the 90mA current that my solenoid is rated at, i put a purely load of 220 Ohm power resistor on the janice.
With this configuration i should have a current around ~100mA.
It all went fine, measuring 24V across the resistor.

Could it be that the load of the solenoid is to inductive?

I then tried with a 100 Ohm resistive load and as soon as the triac turned on something on the board blew out with a loud crack and a little smell.
I was measuring voltage with multimeter probes across my 100 Ohm load as the triac turned on. I do not think i shorted the measurement probes as the triac activated, but i am not 100%.

Right now I do not dare to try another board with the 100 Ohm again.

Try to wire LED’s and proper dropping resistors on all your outputs and test them again. Set resistors for about about 5 mA each.

Triacs are tricky to diagnose with a DVM because the low current running through the meter can sometime not forward bias the triac. So what you are measuring may not be real, unless they are also hooked up to a real load.

Wondering if you over drew total current and the poly-fuse tripped out.

PS the noise was probably the magic smoke escaping from a triac…

Your probably right about the magic smoke ;).

I will try the trick with the LEDs, sounds like a good idea.

What is a DVM, it it short for digital volt meter? If so, I also have access to high quality scopes and other equipment at my university, if this can somehow be useful to resolve the problem?

I have something for you to try …

Set your Janice board aside.

Whatever you’re using for your 24VAC power supply, hook up one solenoid to the power supply directly. Now keep hooking them up in parallel, the next one, the next one.

See how many you can hook up and operate before the power supply can’t supply enough current to power them. I’m wondering if it’s the 24VAC supply that is causing your issues?

The triacs will cause a slight voltage drop, but they are just switches. Your problem should not be caused by anything on the DC side of the triacs … if they turn on, they turn on. Usually, the DC and AC of the triac is separated by an internal optic isolation.

Hello mlseim

I am using a 1000mA 24VAC PSU. I only have one solenoid at the moment, but i tested it on the different outputs on the janice boards. So first i tested the one solenoid in output 1, then in output 2 etc… but only output 5 worked (on another janice only output 6 worked)

If i hook up the solenoid to the 24Vac PSU it works fine.
In regards to the “they turn on if they turn on”, can’t it be something with the impedance of the load if it is somehow purely matched with the phase of the voltage being let thru the triac?


Just to update: Turned out to be “bad chips” as the chinese PCBA company labeled it. The triacs where only “half”-functioning.
Changed the triacs with new ones from a less shady supplier and now it works :slight_smile: