Problematic Routers


Looking for feedback on any routers that have been problematic to keep connected after Blink Up and what was done to correct the issue.

On the flip side, what routers haven’t had any problems with connectivity after Blink Up?

Any feedback would be appreciated.

Thanks, Emil

I have had no issues with a Cisco Linksys E2500, Apple Time Capsule, CradlePoint CBR400, TP-Link, TruConnect (MiFi) and DataJack (MiFi) to name a few.

The only time I’ve recently had issues with connectivity was with a Fortinet firewall that was too locked down. We had to relax some of the rules a bit and then we were good to go.

What kind of problems are you experiencing? Did you have a successful Blink Up (got the green light)?

We’re not aware of any routers with issues (any which allow outbound access to port 31314 at least, which is basically almost all devices in default configurations).

Back a couple of years ago we found some which had buggy DNS relays, but we worked around that with an imp software update.

Do you have a router which does misbehave? We’ve been pointed at a few of these over the years, have acquired exactly the same routers via ebay (same HW rev, same SW rev)… and been unable to replicate any issues…

We had a problem recently using a repeater arrangement of two TP-Link models (TL-MR3220 as master with 3G USB Stick) and (TL-MR3020 as repeater). Any imps connected to the repeater kept firing device.ondisconnect() followed by device.onconnect() every 11.5 seconds (reported at the agent level). This was not a signal quality issue. The devices themselves did not report any local connection issues, but that may have been masked by the imp device trying to re-establish connections in the background. We parked the problem, by swapping out the units for different brands.

Good evening. Thanks for the feedback. I’m perplexed as we seem to be having issues with routers going offline/online repeatedly after successful blink up. In some cases the device will power cycle due to a hard reboot as designed within the firmware.

We’ve solved the problem on some devices by creating a static IP address as opposed to a dynamic IP address, but I don’t believe this level of router reconfiguration should be needed.

Is there a better way to address these issues?

Routers with problems connecting/staying connected include:

  • Cisco Linksys EA 4500
  • Cisco Linksys E3000
  • AT&T 3800hgv-b
  • Apple Airport Extreme, Latest Gen, version 7.7.3 & 7.6.4
  • Netgear 7550
  • Amped Wireless SR10000
  • Verizon FiOS Router Model MI424WR-GEN2
  • Arris DG 950a
  • ASUS N66U 2.4GZH
  • ASUS RTN16
  • Linksys E4200
  • Netgear WN2000RPT extender
  • Actiontec Q1000

I can send more if needed.

That’s very strange. Are these running default settings, or something special?

I have latest airport extreme at home (running 7.7.3), no issues, actually as repeater to a time capsule. The office has a couple of last-gen (flat) extremes, as do several of our employees; the apple stuff is very stable.

We also have an MI424WR in the office (someone reported problems, we bought one but couldn’t replicate any issue), AT&T home gateways (2wire?), Arris (DG860), Asus (N56U), several netgears, at least a couple of linksys, etc.

How close are you to these routers? (ie, what’s your reported RSSI). We have seen “wifi unhappy” reboots - due to the broadcom chip locking up - when this is stronger than -20dBm, which is (from memory) the IEEE spec for wifi sensitivity. Obviously low signal (less than -85dBm) is not good either. Release 30 deals with wifi unhappy seamlessly - no reboot, just a reconnect under the hood.

If you’d like to email more details to your support account, then we can go into more detail there (and push release 30 to units you might want to check with).

Thanks Hugo, let’s connect on support. Is there anyone I can call today to discuss release 30 in more detail? I believe you have my email from my account settings.

Seems like, from the conversation with Frank, that the imps may actually not be falling offline at all (possibly it’s a backend issue outside the imp service). Will email phone#.