Problem getting imp card connecting

I have tried blinking up a new wifi network, but it does not seem to take the change. At least it is no connecting.

I am using iOS app to send the blinks and i’m using imp model 001.

The mode that it end up in before the red led goes out, is “Joining WiFi network”. I have tried resetting the card from the app, but it seems that the card does not react to this.

Thanks for any help,

Martin, tell us more about your wifi router. We will assume it’s like a normal router in a house, in the U.S. and uses channels 1-11. If that is the case, is it possible to try it using someone else’s wifi (like at a friend’s house)? Determine if it’s a router issue or really the imp. The next step is to try blinking in a dimmed room, without much ambient light. Especially no sunlight.

It is a Tilgin router, i’m located in Denmark, and it is using channel 9, mode 802.11bgn 2.4 GHz.

I’ll try another wifi tonight, and when it is dark so the light is not interfering. Thanks for the suggestions.

Works now ! must have been because of the daylight and the blinks did not go through…

Martin, out of curiosity, are you working on a specific project, or just messing around with the imp? Always interesting to know what different applications people come up with.

I see these are still available on Amazon:

Nice to have them available as the imp001 is retired and stock will eventually run out. I’m guessing the imp002 will also fade away as the newer ones come into action.

002 was discontinued a while back - but the breakout is still pretty good for prototyping, and as with all imps it’s still fully supported with new OSes, bugfixes, etc.