Planner background black instead of paper graphic in Chrome

As the subject says, my planner background has gone black. I can see the nodes but not the noodles.

I had thought this was unique to VISTA so I didn’t mention this before - I planned an upgrade.

Yesterday I installed a new drive in my machine and installed Windows 7. The planner background was correct at first but later/now has gone black again. Several other machines with Chrome are working Ok.

My machine is a Dell inspiron 1525 with intel 3000 graphics. I think what is supposed to show is paper.png

any thoughts?

We’ve seen this when using the chrome-dev branch - are you using that or released chrome?

On dev they tend to break canvas support regularly…


23.0.1271.97 m

I think it is the released one. It is a totally fresh to a new HDD Windows 7, then I just ‘googled’ and installed Chrome.

The exact same Chrome version is on another Windows 7 laptop- just checked it this moment (An HP Vision machine) and my one at work also works - likely with the same chrome version.

I have a Google account and use the syncing ability for bookmarks, themes, etc.

It’s pretty strange - seems to be a problem glued to my Dell 1525 Core 2 Duo but I cannot make sense of that.

Hmm, possible it’s a graphics driver issue then, and it just happens that chrome is using the driver in a particular way. Probably worth filing a chrome bug… or trying the dev channel version :slight_smile:

I’ve seen this issue in Chrome for Windows XP and OS X Snow Leopard as well.

Thanks for the help; I’m not going to try the dev channel Chrome because it is just too risky for the small gain. the bookmark syncing is so important to me and I don’t want it broken. That is a considerable risk when using different versions.

I don’t know much about this stuff but my observation is that Chrome works fine for everything except the planner. Seems more likely the bug is in the planner or that the workaround will need to come from the planner.

I would say the evidence points at an issue in your graphic driver, not in Chrome (as it works on other machines) or in the Planner (which works fine in firefox, safari, opera, and every chrome apart from one on your Dell as far as we’re aware). Intel 3000 graphics are pretty common but we’ve not had any other reports of issues.

If you google around for other HTML5 canvas using websites, you may find others which fail on your Dell with Chrome.

Hugo, I think you are pretty much correct. I tried this:

  • installed Firefox - works!
  • booted to safe-mode with networking - Chrome works!
  • installed the dev Chrome “Canary”. This can be done side-by-side: fails
  • regular Chrome: fails
  • I also tried uninstalling Chrome and re-installing and that did not work.

I don’t know enough about the responsibilities here between the graphics driver and the browser but given that Firefox works OK I now have a workaround for this machine.

I am using the standard or Windows approved driver for the intel 965 chipset.

-mjkuwp94 (I have 2 accounts, sorry I posted this using the wrong one)

Is there any plan to change the canvas of the planner to a more basic (white or other “plain” color) to alleviate the black background issue with certain graphics drivers/chipsets and running Chrome browser? I am using the planner on 4 different Windows 7 computers. No problems on three systems, but the black background condition on the fourth (Acer laptop Win 7 64bit Intel 6000 graphics chipset). Changing settings in the Intel graphics setup and Chrome settings make no difference. Thank you.

The plan is to drop the planner in its current form entirely; until then though it’s likely to stay working in much the same way.