Not connecting to certain WiFi

Hello! I’m at Hacker Dojo, where we were given a few imps and dev boards (thanks!).

I’ve been able to get the imps to work at home (and already made a neat monitoring app), but it never works on the Hacker Dojo network. Which is odd because we generally don’t have issues with people connecting to our WiFi. We have both 802.11b, g, and ‘n’ on both bands. They are commercial quality Cisco access points.

We are using WPA2 Personal. No captive portal or anything like that.

Screenshot from my mac:

Most strange. We did have an issue a while back as we misread the IE header in the Cisco AP stuff and thought the dojo network was WPA2-TKIP (it’s WPA2-AES) but I verified the code worked and it went in a couple of releases ago.

Did you try it recently, or a while ago?

I tried it today without luck. It works at home. The screenshot was from today as well. I even tried taking the device close up to the AP.

Ok, looks like I should come over tomorrow afternoon and check this out. Silly question: you are using blinkup to reconfigure this, right?

I ask because if your home AP was also called HackerDojo with the same password, but a different encryption type, you might expect it to work but it wouldn’t because we cache the encryption type on successful connect.