Noodle is not joining nodes in the wiki example

Upload code:
Add ticktock node
Add noodle
Click Blink-O-Matic node

Error show on screen: This impee has no sync nodes you can connect

Hi reefangel

Yeah, I just experienced something similar today.  I’ve logged a bug.  I did find that if you keep trying to connect, eventually you’ll make a successful connection. Can’t say what I did differently from one attempt to the next.  You can tell that it’s a successful connection when the the noodle shows “0” at both ends and then a dialog pops up asking you to confirm connection.

Can you give it a few attempts (like 10) and let me know if you’ve manage to make a connection?  Thanks!

I was able to make a connection if I declare an output.
<br>// Blink-O-Matic example code with remote control<br>&nbsp;<br>// Variable to represent LED state<br>local ledState = 0;<br>&nbsp;<br>// Variable to represent LED inhibit state<br>local inhibit = 0;<br>&nbsp;<br>// blink function called every 100ms<br>function blink()<br>{<br>&nbsp;&nbsp;&nbsp; // Check if we've been switched off<br>&nbsp;&nbsp;&nbsp; if(inhibit)<br>&nbsp;&nbsp;&nbsp; {<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; // Blinking inhibited, turn off the LED<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; hardware.pin9.write(0);<br>&nbsp;&nbsp;&nbsp; }<br>&nbsp;&nbsp;&nbsp; else<br>&nbsp;&nbsp;&nbsp; {<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; // Change state<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ledState = ledState?0:1;<br>&nbsp;<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; // Reflect state to the pin<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; hardware.pin9.write(ledState);<br>&nbsp;<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; // Schedule the next state change<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; imp.wakeup(0.1, blink);<br>&nbsp;&nbsp;&nbsp; }<br>}<br>&nbsp;<br>// input class for LED control channel<br>class input extends InputPort<br>{<br>&nbsp; name = "LED control"<br>&nbsp; type = "number"<br>&nbsp;<br>&nbsp; function set(value)<br>&nbsp; {<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; if(value == 0)<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; // 0 = Inhibit LED operation<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; inhibit = 1;<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; }<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; else<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; // 1 = Enable LED operation<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; inhibit = 0;<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; blink();<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; }<br>&nbsp; }<br>}<br>class output extends OutputPort<br>{<br><br>}<br>&nbsp;<br>// Configure pin 9 as an open drain output with internal pull up<br>hardware.pin9.configure(DIGITAL_OUT_OD_PULLUP);<br>&nbsp;<br>// Register with the server<br>imp.configure("Blink-O-Matic", [input()], [output()]);<br>&nbsp;<br>// Start blinking<br>blink();<br>&nbsp;<br>// End of code.<br>

Yes, I kept trying and indeed after several attempts, it took my connection asking me for a selection.

I’m having problems with this code too:

When I load it, it makes my imp unresponsive and it goes offline.
Then, I need to save a simple code like “Hello Word” and reboot imp for it to be responsive again.

Yeah, code worked fine previously but we’ve made some changes it’s not working as expected. We’ve checked in a fix that should be available soon. For now, please don’t try Light Switch and AC Dimmer examples.  'Til then, I’ve noted as such in the dev wiki.


Note that a temporary workaround is to do an “imp.sleep(0.01)” between the set() calls. The fix should get pushed tomorrow and your imp will auto-update.

Thanks a lot!!
So, this is what I have read about sending data too fast… Now what I know what it meant :slight_smile:

The noodle + node connect issue seems to have been resolved at the moment altho no fixes were implemented and I’ve not been able to reproduce it today.  I’m running the original Blink-o-Matic example code: 

// Register with the server
imp.configure(“Blink-O-Matic”, [input()], []);

Still, don’t think the problem has really been fixed.