New imp001 will not connect


#1

after blink up I am getting a series of flashes then constant red…the flashes go quickly; yellow, then red, then red/yellow, then yellow red green then a pause and then constant red. I have cleared and re-blinked a couple of times only to see the same issue. Any ideas?


#2

You may already have seen this webpage, it even has some “play” buttons to visualise the flashes on an imp001:

https://electricimp.com/docs/troubleshooting/blinkup/

The first hint of a green flash (other than a single green flash a millisecond after blinkup) usually means you’re on the home straight as the Imp has made contact with the server. Perhaps if you post the MAC address laser etched onto the Imp the EI guys can look it up in the logs.


#3

Thanks, I did go through that page but none of the sequences matched what mine was doing. The mac is 0c2a6901ff03


#4

How are you powering the imp001? Constant red suggests a power issue: it’s not a formal LED pattern but an artifact of the impact of the power issue.


#5

I have used both a new 9v battery and the usb power supply with the same result.


#6

Is there any way to check the pins of the card socket to make sure the voltage is making it to that point?


#7

I can continually clear the device and reblink it so the power is probably not the issue. On further inspection, it appears the sequence of flashes are the imp searching for the network, joining then getting the IP address ect…apparently, once connected it is having a problem. The last flash before getting the constant red is a quick green flash which appears to be the indicator for the imp being connected to the server. There is then a long pause then the constant red. Considering constant red is not listed in the status codes and no one apparently has seen that before, is it possible that I purchased a defective imp? Should I see about returning it for another one? If so, do I return to Digikey or Imp?


#8

Constant red is a known event, as it says on the Troubleshooting page (at the end of the ‘Common BlinkUp Problems and Their Solutions’ section). If the imp is behaving itself, you’ll see it flash green (connected to server) for a couple of minutes and then the LED will turn off. I’m assuming you haven’t entered any device code yet, so there’s no application for it to run.

You’re using the Electric Imp app to BlinkUp, right? What does it say after BlinkUp has completed? Do you get a Device ID back? If so, post it here and I can check it in the log data.

PS. If you want to replace this imp001 anyway, please contact Digikey.


#9

The ap says device failed to connect. Sorry, you are right about the staying red being a listed problem but it is attributed to an insufficient power supply and I have tried a new battery as well as the usb power with the same result. I feel like I have eliminated the possibility of it being a power supply problem. Unless the board is the issue. Is there any way to check voltage at the SD card socket to find out if the board is delivering the available voltage to the Imp?


#10

Check the 3V3 pin on the board: it should give you a reading of what’s going into the imp after the input voltage has been lowered for imp usage.


#11

It reads 3.28 volts


#12

According to the notes on power supply: “A device’s embedded imp is designed to be driven by a 3.3V DC power supply, commonly derived from a 5V USB feed or from connected batteries. The imp’s operational power range is 1.8-3.6V, but WiFi requires at least 2.5V. If the supply voltage drops below 2.5V, the imp will continue to process Squirrel code (provided the supply is 1.8V or greater) but WiFi will be disabled.” I should therefore have plenty of power to drive the imp if the 3V3 is an accurate check point…any other ideas?


#13

Only to double check that you have the network settings correct, ie. that you have entered the password correctly, and that you’re network’s not 5GHz (needs to be 2.4GHz) and operating on channels 1 through 11. This is to categorically rule out network issues. I don’t think that’s the problem, but it’s certainly worth confirming that it’s not the problem. That done, it’s probably worth getting a replacement from Digikey.


#14

Thanks Smitty, I did already check the password and also saw that the Imp001 will not work on 5ghz so did that but did not see the channel 1 thru 11 limitation. I honestly don’t even know what that means but will figure it out. Thanks for helping me with this.


#15

Opened the router settings and verified the imp is trying to connect to wifi channel 7 at 20mhz and still same problem. I will send this one back and post again when the replacement is tried.


#16

Just got off the phone with Craig at Digikey and we tested all the pins from the card socket to the board and came to the conclusion that the breakout board is bad, not the Imp. They are sending a new board out and I will post the results when I get it…


#17

For future reference, which pins were tested and found to be an incorrect voltage? What was the voltage and what should it have been?