New AP, old SSID/password, not connecting


#1

Have several developer imps on site. Occasionally swap AP/routers for different models. Always stuck to the same SSID/password so blinked-up once long time ago and never had any issues with imps connecting to new APs. Until now - just installed Netgear Orbi mesh and getting very erratic behaviour. One imp device simply refuses to connnect flashing red—red-red-red or red—red-red.
Others will connect but disconnect after a few minutes and stay disconnected (WiFi outage error). Had thought of too-strong RF issue but get no change out of moving behind several walls. No imps will work reliably in an environment that has previously been trouble-free. I’m assuming that blink-up only exchanges SSID & password right? Reverted to previous wireless network setup and all is well again.


#2

I have also tried resetting the imp settings and started up the Orbi AC3000 router on a new ssid/password and entering these credentials using blink-up. Blink-up succeeds (green flash) then immediately resorts to red----red-red.
I’ve confirmed that 2.4GHz is broadcasting OK by connecting another 2.4GHz-only client.


#3

That pattern indicates the imp is either not finding the network (incorrect SSID) or is not joining the network (correct SSID, incorrect password), so you should check those.

I know that some mesh systems don’t allow you to separate out the 2.4GHz and 5GHz networks, and I wonder if its steering the imp to the (incompatible) 5GHz network somehow.


#4

Also a token that’s retrieved from the impCentral API. This is used to associate the device with a particular account when it connects. This is why you need to provide credentials to the BlinkUp app.

Production BlinkUp is slightly different, but that’s not important right now.


#5

The crucial thing here is that BlinkUp is working – you get the green signal – so your issue is not getting settings onto the imp, but how the imp is interacting (or not) with the router.

PS. You can tap the eye icon in the WiFi password field to view the password as you enter it. I find it’s way to easy on mobile phone keypads to mis-enter long passwords, and without sight of what you’ve entered you don’t know you got it wrong until the imp fails to connect. Just got to watch out for all those hackers queueing up behind you to peer over your shoulder and catch a glimpse of it… :slight_smile:


#6

I think the problem may have bee due to a quirk of the Orbi system. It’s extremely slow to sync config changes between the base router and satellite(s). In the order of 5 minutes so it seems - sometimes not at all until everything is power cycled. So after I manually set the 2.4GHz channel to ensure it was one the imp would be happy with, while it looked like the channel had changed (double checking on my smartphone connected to the base AP) however the satellite (which imp was connected to) possibly hadn’t. This could have meant it was faced with connecting to channel 13. I’m not sure, but after a few times over resetting the Orbi firmware, I noticed it seems to have an unfortunate habit of auto-selecting this no-no channel for imp01!

After nailing down the channel usage throughout the entire network I’m hopeful that all the imps will stay connected now.

While Orbi also uses the same SSID for 2.4 & 5 GHz radios, I don’t think this can cause a problem. Presumably the imp RF hardware will be oblivious of the signal. What I don’t understand about the system is that base and satellites all sit on the same RF channel for each of the two WiFi bands. When I’ve connected multiple APs together to get a poor-mans mesh, I’ve used the same SSID but spaced the channels apart eg. 1, 6 & 11 fearing that overlapping coverage may result in interference. I guess they know what they’re doing.:face_with_raised_eyebrow:


#7

I have two Orbi setups; the only issue I’ve seen is that one of my satellites, every few months, just decides to stop doing 2.4G. It’s still happily doing 5, but 2.4 has just turned off.

Power cycling it fixes the issue. No issues with the master device… Orbi coverage is great but reliability is so-so…


#8

Skimming the Netgear forums it seems like the latest firmware might be regressive. Yet to find a version that people are happy with. I also suspect that there’s always going to be potential for trouble in zones with overlapping radio coverage - clients clearly closest to one or other AP seem to do fine but being half-way between leads to frequent reconnections (as suggested by our imp-enabled Roomba :wink:)