Need help recommissioning imp


#1

I was trying to get the “Hello World” example working, but for whatever reason I couldn’t get the Hello World text to show up in the imp node associated with my impee as it does in the example. After fighting with this for sometime, I deleted the node in the hopes of starting over. I cleared the wireless configuration from the imp card and the impee no longer showed up in my planner.

Now when I try to use BlinkUp, I’ll get a few 2Hz green pulses followed by 2 or 3 faster red pulses. I think this means that it’s losing the connection. Furthermore, nothing at all is showing up in my imp planner. There’s no node associated with an impee and nothing shows up in my list of impees. I have tried doing BlinkUp about 10 times now with the same result.

What’s the proper way to get this all reset so I can start over? How should I have gone about this in the first place? The imp node and impee had shown up with no problem before.


#2

What happened there is that your code was crashing (red flashes) before it got to the imp.configure line, and you’d deleted the node from the planner.

The correct fix is to get rid of the bug in your code, then it will reappear in the planner.

There’s a bug on our side in that we should, if a device fails to configure within a timeout, still appear on the planner to allow easy access to it.


#3

To be more specific, I’m getting three slow green flashes, followed by two quick red flashes followed very quickly by the first green flash of the next sequence. Am I losing the connection and attempting to reconnect constantly?


#4

I ended up getting back on track by clearing the wifi data again and commissioning the imp to a new account, but I’m still curious what the right thing to do in that situation is.


#5

ahhh, i have the same issue! i’ve reverted all my code to the ‘hello world’ example but still can’t get my imp back. is there anything else i can do to recover my impee?


#6

it automagically appeared again after coming back to my laptop after a long meal!