Need a little help starting up, No device connected

I just got my Imp and connected through a Sparkfun Breakout, powered it up, Blinkuped through my Iphone. The Imp flashed green afterwards. My Impee is listed as: 2340513643fc42ee.

I setup “Hello World” in the tutorial:
//Hello World example code

// Register with the server
imp.configure(“First Program”, [], []);

// Display our important message“Hello, World!”);

// End of code.

But, It does not show it working on the planner. The Node says blank. When I look at the code, there are no errors. The log says “No device Connected”.


dang. Figured it out after I wrote the post. I made another code with nothing in it, ran it, then reran Hello World and it worked. Wahoo.

I think the main problem was you needed to pick your new firmware to run on the impee showing as “blank” - but I guess that happened when you switched code above :slight_smile:

I had this same problem.
I think there is a small glitch when loading the first program with just 1 code available
I had the same Blank message and the “run code” button was disabled on the code editor.
Anyways, making a new code solves this issue (maybe a note in the wiki would help)

I also had this same issue. Creating a blank program also worked for me. This was very frustrating for me until I found this thread.

Yes this is very frustrating problem of imp.
To solve that we create a blank program.
Only then solves.

It took me days to realize that.

Thanks for everyone’s help