My imp does not say Developer Edition

Are there 2 versions? A Developer Edition and ??
I can not get anything other than yellow blinking lights. Tired blink up many times with different combinations of setting from my Samsung G4. I will try an iphone or ipad tonight when I get home.

Hi Kevin - Developer Edition imps, and non-developer edition imps are identical except for the markings on the card.

Have you tried the steps suggested in our BlinkUp Troubleshooting Guide?

Specifically, make sure power save mode is turned off, screen brightness is at maximum, and if it’s the first time you are using BlinkUp on the imp, select “Legacy Mode.”

Additionally, when you are performing BlinkUp, make sure the imp is powered on and blinking, and that the screen of your phone is as close as possible to the optical sensor. You can find more detailed instructions here.

Thanks for the reply. Yes, I have read and tried these things. Never anything except yellow blinks. Over 20 different attempts. I will receive read and try again. Maybe an iPhone will work.

Apple devices tend to have higher reliability with BlinkUp because iOS prioritizes stable framerates, which Android does not :frowning:

Where did you get the imp from? If the imp is from a commercial product I would make a guess that it is locked out in some way. I have done blink-up with Android devices. old Galaxy S and a Motorola Xoom - also old. The main trick I have used is to keep the card near the side of the screen closer to where the backlights are.

Bought it from spark fun last week. I hope it is brand new. I’ll try closer to the edge of the screen.



which of the LED codes do you get? Perhaps double-check the wifi password by logging out of your network and back in? (I’ve been known to forget mine).

I have had trouble once in a while but never taken 20 tries. not to say you couldn’t have a problem but this seems a bit severe.

Yea, that is what I thought :slight_smile: it was getting late last night. Will re confirm the password and let you know.

You may need to use “legacy mode” for the first blinkup with android too.

OK, legacy mode from my Samsung 10.1 tablet. I can see the device on the IDE. Thanks.