My Imp didnt show the green light

The following are my procedures to connect the imp. Could you please advise why no green light showing? Are my procedures below are correct? Thanks. Emily

  1. Register a account on
  2. I used IPHONE so I downloaded the apps from apple store.
  3. Plug in the Imp into the April board
  4. Then plug in the April board electricity by USB cable
  5. Run the apps at IPhone
  6. Entry the Electricimp account details, select my home Wifi and enter password
  7. unplug and re-insert the imp to the April board, then the orange light is flashing for a moment.
  8. When it stops flashing, I pressed “SEND BLINKUP” on my IPHONE and let the sensor of Imp faceing to my IPHONE screeen.
  9. No response on imp, no light up.
    Remark: I live in Hong Kong. Will it be related to my Wifi setting in Hong Kong?

Only use wifi channel 1-11

I just wanted to add my notes/experience to this thread for future reference.

I too had problems getting up and running. I first attempted using the iPhone app on my iPad to configure the imp and I would end up with the flashing orange/red. I would use the app to clear settings and it would give me the “success” green flash. I would cycle power and try again to no avail. I then attempted the same with the Android app and couldn’t get it to work either. Based on info in this thread I set up a wide open / unprotected wi-fi hotspot on my cellphone and was then able to set up the imp using the Android app to connect to that. Once connected, I was under the assumption that it would need an update, so I let it sit awhile while I did something else. When I returned I attempted to reconfigure the imp using the Android app and the protected WiFi network info. I got the “green success” blink, but then flashing rad that would timeout and shut down the imp. After several attempts I noticed that the Android app was adding double-quotes to the SSID textfield automagically. I removed the double-quotes and was then able to successfully configure the imp to connected to my encrypted WiFi. As I used the imp throughout the same day, it connected flawlessly and continuously to the encrypted network.

I hope this helps out somebody and/or prompts a look at (at least) the Android app’s quote issue.

They should have just used a simple internet web page to send to the imp. Plug it in type your stuff and done. The mobile app adds nothing but complicity to something that should be the simplest part - set up. Why did you use this silly blink technology with such a cool product. I used this 5 years ago with my Garmin device. Over engineered. I used my Android, iPad, iPhone but still can not get it to work!

hmm, how do you send something to the imp when it is not configured?


On the 15th time it worked but I really had to cover the board with both my hands. It could have been so much easier. It is going to be hard to put the 15 or 20 I want for my sensor network. I have good hopes for the next versions.

I suppose, in your case, it would be a whole different product.
An USB connector would require an additional piece of hardware, even if there is room for additional connectors (or reconfigure existing ones).

A cheap ($20) FTDI USB-to-Serial cable could easily do the job, when connected to one of the imp’s serial ports, if only it was supported by the imp’s firmware.
The optical data transfer is elegant in theory, but quite cumbersome in practice for a lot of users. It almost never works on the first try, and only if you have a compatible smartphone. But then again, a wired connection needs physical access to the imp though a connector, which adds cost to the end product, and requires the (non-technical) end user to attach a pc and run some kind of setup program. Connecting to wifi always requires some user effort. WPS might be the simplest solution for non-technical users.

Cheap??? It almost doubles the cost for the first Imp
Even the last solution requires a WPS-enabled router.
At the moment you have three options: Apple, Android and Windows, without additional costs. The number of people that has problems with commissioning the Imp isn’t that high IMHO and I believe they are still working on improving the blink up solution.

I have to disagree with the optical setup not working: it works basically first time every time in my experience (with an iOS device). Android is a little trickier - quite a few phones require half-speed mode - but we have some stuff coming up that fixes that too.

The usual issue is that there’s too much ambient light. The system is designed to work in products that have imp slots in them, so the only place for light to come in is through the light pipe on the card’s edge - an un-housed devboard means you need to put a thumb over the logo on the imp to prevent light leakage. Tom’s video here - with an android phone - shows how best to do it with an April devboard:

It’s not possible to have an electrical method because, well, all the IO pins may be in use by the application. The other thing is that auth tokens are passed optically - just using WPS doesn’t get this across.

If you’re waiting for a new version of the imp card that doesn’t use optical setup, you have a long wait ahead of you!

Or quite possibly the imp is not the best device to use for your particular need. There are other WiFi devices/controllers on the market. The imp is an interesting device, it fills a niche (cost, ease of use), and it is what it is. I blinked my imp on the first try with an old Windows Vista PC and a basic LCD monitor. In fact, I had already convinced myself that the blink-up would fail after reading about everyone’s troubles, so I didn’t think it worked. But I was good to go.

Thanks for the video.

I am using an ipod touch 2nd generation. I have successfully installed the app. However, the screen does not blink.

Any thoughts?

I’m not sure the ipod touch 2nd gen is supported for the blink. I think it can depend on the version of iOS.

About the issues commissioning the imp001 with Android based phones, I use a very simple trick: cover with two fingers the top of the card and keep the couple (card and phone) far away from the window and direct source of light.

The reason I use to fingers and not one like shown in the video is very simple: with two fingers I can cover the whole card but the LED will be in the middle between the two fingers’ tips so I can see it and catch the fast green flash that shows everything is good.

Since I use this trick I haven’t miss a single commissioning using the whole family of Nexus since the One.