Murata Imp 005 problems connecting to WiFi in USA


I’ve recently got back from creating an Imp driven installation in New York, similar to the one I did for Airbnb last year at Sundance, involving live printing of tweets. This time though I decided to use the Murata 005 board rather than the trusty 001. I tested everything before leaving for the states and it all worked great, connecting to the Wifi without a problem.

However, when I got on site at the Flatiron building none of the boards would connect to the Wifi that had been setup. I was assured the wifi wasn’t using WPS. I could could connect other devices to the wifi, just not the imps, even trying a different Wifi hotspot. In the end I had to create personal hotspots on my iPhone and have the imps connect to that which worked fine, though it meant leaving my phone on site for two days!

I bought the 005s from Digikey, which I believe were sent from the USA. Am I right in thinking that there could have been an issue with US wifi versus UK wifi? Never had this problem before, 001s always worked perfectly. Think I’ll be sticking to them in future!

Can anyone shed any light on what this would have been?



I see that you had the Imp005 working in the U.S. I was going to question if Digikey was providing the breakout board with a pre-loaded flash (ImpOS image). Looking at Digikey documentation, I don’t see any mention of that.

Did the working Imp005 you had come from the Imp store (with pre-loaded flash), or did the working Imp005 you used come from Digikey or Mouser Electronics? Maybe this is the issue?

The default country code is US for the devboards - the wifi that had been set up, do you have any more details about it? Seems like this is the unknown.

Did you have any 001’s with you that you tried with the NY wifi?

The guy who set the wifi up didn’t know too much about it - it was a black briefcase type thing, and he just turned it on and said it’s “just normal wifi”. I didn’t have any 001’s to try unfortunately. I did try it with another wifi unit and it did the same, just wouldn’t connect, seemed to be negotiating constantly.

Certainly a weird one, and at least I found a workaround at the last minute!

The imp005 breakout boards Digikey is selling are all tested through the same flow as those Electric Imp sells.

During testing the flash image is verified and the imp’s ability to connect via wifi and ethernet are tested.