Lost C3V0 network

I have had a C3V0 working for a while. This morning I came down to continue working and the green led for network was off; I have seen this before but it was always still connected to the cloud. This time the device was off line. I power cycled the imp and it will flash some but never connect. Here are the really odd things;
The flash codes never seem to be consistant between power cycles. I will see a Red, very very short Red, repeat and then go solid red. I have also seen Red long, red, red, red, pause repeat. It almost alway ends up with either a solid red or no led at all. I have tried re-blinking it many times. Twice it went green for about 30 seconds and then off again. Of note; the code on the imp did not change from night before when it ran, the network has not changed, I check the firmware on the router, just in case of auto update, and it is from June. My guess is a power problem by watching the LEDs since even the green power LED will dim some times. My last attempt was to unplug the imp from the board, set it on the table and power it via USB, no joy, same issue.

Did something change on the dev cloud last night and update the IMP002 firmware?
Any idea what solid red on an IMP002 is? I looked at the imp blink up troubleshooting guide and it is IMP001 with amber led.
Is there a trouble shooting guide for IMP002 blink up?

Any other ideas?

BlinkUp codes are the same for all imps. The codes you are referencing sound like the imp is having trouble finding or connecting to your network.

If the imp were not getting enough current to completely power the radio, it would most likely just blink short red over and over in a boot loop.

Try resetting your wireless router or trying to connect to a different network?

So, is amber green and red on at the same time? The imp trouble shooting shows Amber. Also, there is no solid red in the trouble shooting guide for blinkup

Is there an led code for boot up?


I tried a few more things; I did try a guest network which seem to show even different results. No idea why but it has connected now on the old network, what I did was unplug the USB and connect it back to the lipo battery, re-blink it and it connects. Now I can do everything I use to do and works. No idea why, no changes from what I can see other than changing the power source from USB to battery and connecting to a different network for a short time. BTW, the guest network was stuck in connecting to server amber,off, red. Also of note; in the previous post, there was never a amber/red – in other words there was one color – not seeing the other makes it hard to know if it was amber or red; but it was only one flashing color.

Still would like to know what solid red is?
What is the very short flashes that it seem to get stuck with?

I have had strange, undocumented blink-up codes before and traced it to a power problem. In my case I had a lab power supply set to current-limit at too low a value so it was really easy to just turn the current-limit up by turning the knob on the supply. The imp module wants 400mA peak as I recall and of course if you have other things connected to the board these need to be considered as well. (I use a 300mA rated power supply but have virtually no other load… and I am not 100% free of connection trouble so my 300mA supply is probably marginal)

Amber is Red+Green.

It is also possible for bad squirrel code to cause trouble with hooking up to the network - ask me how I know this ; )

With blink-up you should look for the one short green blip after the flashing stops. This means the data got to your imp OK.

are you making any calls to:

server.setsendtimeoutpolicy ?

No calls to setsendtimeoutpolicy. Odd that with really no changes that make sense this thing started to work. I do have other small loads on the 3V system and according to makedeck, their switcher is 500mA so I could be close, I can easily do a load calculation. I need better than 3V to run the motor controller so its vin is 5V, that same vin is on the C3V3 vin. The motor board logic is at the imp level.
When you see LEDs fade in and out, barely blink and do other really odd things it points to power, I just cannot figure out why it would “start to work” now.

Thanks for the replies.


Solid red/erratic or very fast red blinking is almost always a power supply issue. The imp boots, turns the red LED on and then tries to get wifi out of bed but the power wifi takes kills the voltage and the imp resets and tries again… and repeat.