iPhone and iPad Blink Up failed


I am having troubles in blinking up my imp with my iPhone and iPad. I tried everything: covered the top of the Imp, used a piece of black tape, checked the battery charge status of the device, the screen is at its maximum brightness, everything. I know that the Imp works because on my Android phone I can correctly blink up my Imp in “Legacy mode”. But I didn’t find that mode for the iPhone App.

Is there something I can do to correctly blink up the device with iPhone or iPad? Is there something I must care about when doing the blink up process with those devices? I do really need help.

Thank you.

There is no legacy mode for iOS devices, as Apple hardware has a consistent refresh rate. Usually the problem is the other way around.

When you start the BlinkUp process, does the Red/Green LED stop blinking? When the BlinkUp flashing finishes, do you see a single green flash before other codes?

What are you using to power the Imp? Could it be a current issue? If you don’t aren’t supplying enough current at the start, the Imp will not be able to connect to WiFi.

Have you tried to first ‘Clear Wireless Configuration’ prior to blink up? I recall a time or two where I experienced a similar problem - (general unexplained blink up frustration that is) - and this worked for me. Just a thought for something add’l to perhaps try if you haven’t yet.

Which iphone/ipad and which OS version?

Hi to all and thank you for your help. Here there are more details…

I tried on iPhone 4, 4S, iPad 2, iPad Air all with latest (as of today) OS 7 installs, and yes, tried the clear configuration, etc. And using power via direct connection via USB, same connection that works with Android. Direct to PC and thru powered 5A USB hub.

Android works perfectly on legacy mode, 3 out of 5 in normal mode, but with the iPhones, just doesn’t seem to want to handshake.

Bottom line on Android devices, ALL will work, but not all on “normal” mode, many need legacy mode. On IOS devices, can’t seem to get any to blink up.

Ordered 2 more IMPs to see if behavior is the same. By the way is there any update of the IOS application available?


Very very strange. “Legacy mode” isn’t required on iOS, because iOS doesn’t drop frames as a rule.

Does the imp LED just not stop flashing?