Incorrect "device online" message in IDE

I am working with 2 imps that are using the same active model. The code I’ve been using has worked fine for a couple of weeks.

I made a tweak today then did a build and run that pushed the new code out. It now seems like both imps are sharing the same agent link. Now if I build and run something for one of the imps it updates both imps. If update for the other - it doesn’t affect either.

I reloaded the “Hello World” code from the dev center to help troubleshoot and it’s behaving the same way.

Also - I have all all imps powered down but I’m still seeing “device online” messages for both:

Please assist.


I’ve passed this on to a couple folks to dig into deeper. A couple follow up questions:

  1. Have you tried power cycling your imps yet?
  2. Which agent url is acting as active for both imps, and which agent url isn’t working for either?
  1. Yes.
  2. Reuz5g5pxwmR is the one that is pushing code to both.

That URL is different from the two agent urls you’re showing the Dev Center… also, what do you mean by “pushing code to both.”

(if two devices are the same model, they will be sharing the same code - it’s not the same agent, but code is bound to a model, not to a device)

Clarification on ‘pushing code’ - it’s really switching models. More specifically:

  • When I switch the model for Reuz5g5pxwmR from my “ACROSS: Sensor Code” model to “Hello World” model - BOTH Reuz5g5pxwmR and NE6oEtuxYUze blink the LED.
  • When I switch the model for NE6oEtuxYUze from my “ACROSS: Sensor Code” model to “Hello World” model - NEITHER Reuz5g5pxwmR and NE6oEtuxYUze blink the LED.

I am using the same dev board for both and switching out the cards.

Hope this helps. Thanks for the quick reply.

Code is device specific, not card specific (ie - the code that is run on the card is determined by what board you plug it into).

This is so that you can have many projects (or imp products) and only one card.

Basically, each April board has a chip on it that provides a unique ID. When you plug your imp into that board, it grabs the ID, then asks the Electric Imp servers what code should be run for that board. If the card doesn’t have the proper code, or if the code is out of date, it fetches the latest version than starts running it.

It sounds like you have two devices in your account (do you have another April board, etc laying around you used before?) - but are only using one of them (and switching cards).

Yes! That clears it up.

We have 3 April boards (and 3 cards) we have been using off and on but I recently switched to just one for testing. That’s when the problem started and that explains it.

Resolved! Thanks.