impOS release 32 now rolling out to developer devices

Release notes are here:

The big nice things you’ll find here are:

  • Essentially double the available code space on the imp
  • Usually, more free RAM too
  • A more reliable, faster upgrader
  • Many improvements to connectivity

imp.getsoftwareversion() returns: “d7fb311 - release-32.10 - Tue Jun 16 11:12:52 2015”

Enjoy, and please note anything you notice (good or bad) in this thread.

The rollout is now complete to existing developer devices, but brand new devices won’t get it just yet (all remaining devices will get this on 6th July).

If you have a device that doesn’t have 32 and you’d like it, please let us know the mac address.

Today my IMP003 upgraded firmware, few minutes later I saw this.

2015-06-26 15:11:54 UTC-7 [Exit Code] imp restarted, reason: out of stack
2015-06-26 15:11:54 UTC-7 [Status] Device connected

What does it mean?

That means that one of the impOS internal threads got too close to it’s stack limit, so the imp did a controlled restart before any memory corruption could occur. If you can share your squirrel code via either a PM or support ticket we’ll take a look.

Release 32.12 with some bugs found during developer testing is now rolling out to developer imps. You should notice the new, ultra-fast (~8-12 second, usually) upgrade if you’re looking out for it :slight_smile:

My developer IMP still shows ff9c71d - release-30.23 - Wed Oct 22 23:05:56 2014. How is the firmware update triggered? I tried clearing wireless configuration.

If your device wasn’t getting 32 it wasn’t recently active when we queued developer devices. It should update later today when we move the “stable” version for everyon to 32.12.

now firmware updated was triggered. But it kept blinking red.
2015-07-20 15:03:31 UTC-7 [Status] firmware update triggered
2015-07-20 15:03:35 UTC-7 [Status] Device disconnected

Now it blinks device disconnected

Strange. Got a mac address?

If it’s 0c2a690be208 then that one doesn’t appear to be able to reach our upgrade servers. Any restrictions on port 80 to


Now i connected my windows PC to the same wifi network as the imp and used cmd to ping to ( and the request is timed out. 4 packets sent and 0 received.

ICMP is turned off, try browsing to it.

I just improved one ground connection in the circuit. Now impOS upgraded successfully. Not sure if the problem was related to the ground connection or related to something in the network. I tried the webbrowser and it returns 404 not found. Pinging to returned Request timed out. Could it be that you changed something in the server that made the upgrade successful?

Also another IMP003 was struggling with impOS upgrade for 15 minutes.

2015-07-20 17:55:40 UTC-7 [Status] firmware update triggered
2015-07-20 17:55:43 UTC-7 [Status] firmware update triggered
2015-07-20 17:55:45 UTC-7 [Status] firmware update triggered
2015-07-20 17:55:47 UTC-7 [Status] Device disconnected

2015-07-20 18:11:53 UTC-7 [Status] firmware update triggered
2015-07-20 18:12:28 UTC-7 [Status] Device disconnected
2015-07-20 18:12:42 UTC-7 [Exit Code] imp OS upgraded

Not sure why. Do you have an idea?

Upgrade server has not changed, no. If a browser returns 404 from our end then the connectivity is fine, and as I said ICMP is turned off for those servers so you won’t be able to ping them.

Could you file a support ticket about your other imp003? We’ve had other 003’s upgrade just fine so I’m not sure what problem you’re seeing here.