IMP002 in (old) SmartMaker IMP002 Breakout; cannot blink

I had this working some time ago, then it was shelved and I have just tried to resurrect it.

I have individual red and green leds, and the phototransistor all in place, with appropriate resistors.

On powering up, both the green and red LEDs come on steady. After 71 seconds the red goes off and the green stays on.

Have tried different power supplies, same result.

Any idea what is happening ?


If the green stays on, I think your Imp is getting new software downloaded (revision change). Walk away and come back later to see if the green LED goes off.

It sits at green forever (or at least several hours so far!). It’s definitely not connected to WiFi - have sniffed for mac address. The startup process should involved some flashing of the green and red LEDs, but they both come on solid for the first 71 seconds. Incidentally the 71 seconds is repeatable, not random. Which makes me think there is something going on with the module …

Bit strange. Do you have the 10k resistor across the red LED? That’s the polarity detect. Both LEDs should be booked to either ground or vcc (ie common anode or common cathode). Are they?

No, I don’t ! I just have a 220 ohm resistor from each of the break out pins to the anode (+) of the LED and the other leg of the LED (-) to ground. Sounds like I need a 10k across the red LED ?? How did I miss that ?? Will give it a go … thanks !

I was looking at … does not mention anything across the red LED … I do have the bias resistor across the phototransistor, though. Which worked before.

Ok, have now looked at datasheet again. And have put the 10K resistor in, but same as before … it was working in common cathode mode without the 10K resistor there. Beginning to think IMP module has died a death :frowning: How can I definitively check I wonder ?