IMP stopped working

I am unable to connect to my IMP since yesterday. The last log I see is
2014-04-08 06:28:24 UTC+5.5: [Status] Device disconnected; 45 bytes sent, 0 received, 45 total

Now if I power of the device the device either show RED light (not blinking) or some times the RED led blinks. I used the iOS app to reprogram my WiFi password after the the LED became GREEN (not blinking) but I don’t see IMP connection on my WiFi router. The behavior is really unpredictable some times when I switch it on it show RED light and some time the RED LED blinks. How do I debug what is going wrong ?
The device status is shown offline in the IDE. I have been using it for 2 months without any issue.

Red light not blinking usually indicates a hardware problem. Do you have any other devices (impees) to try your card in?


Unfortunately no :frowning:
Can you provide any pointers on how to figure out exactly what is wrong in the hardware. Any test points to probe ?

Also some times it go to GREEN and stays in this state forever. Any way to figure out what exactly is happening inside the IMP when this happens ?

Whenever we forcibly push new firmware (improms), it will go solid green for up to several minutes (then back to normal). For solid red, the main test point to probe should be the input voltage: the imp will boot at much lower voltages than the wifi will work at.


If you can provide the mac address, we can look in the logs and might be able to see what it’s up to.

What board is it plugged into, and how is it powered?

MAC is 0c2a69003be4.
I have powered it over USB using a wall charger of a phone and I am using the April Breakout board bought from

Is there a way to power on the IMP without the board. Just to check if the problem is in the IMP or in the breakout board ?

@Hugo can you please let me know if you have any updates from your logs.

Also please let me know if there a way to power on the IMP without the board. Just to check if the problem is in the IMP or in the breakout board ?

Also please let me know if there a way to power on the IMP without the board. Just to check if the problem is in the IMP or in the breakout board ?
This is not possible, Imp cannot connect without a device ID.

Sorry, I’ve been traveling and not had a chance to catch up with the forums.

Had a look in the logs and the last time we saw it was when you last saw it - 4/7 UTC. Do you have a meter to check the april board is providing 3.3v?

I will buy a meter to check the input voltage. Do you have any document/link on basic troubleshooting using a meter ?

This one looks good:

I was actually interested in a doc/link about how to trouble shoot the IMP and the April board. Which points to test on the board ? Is there a way to externally power the IMP. I do know how to use a multimeter. I just need some info on what to check on the April Board and IMP.

First check you get 3.3v between the GND and 3V3 pins on the edge of the april. No you can’t power the imp without a socket, ID chip, etc - basically, without an april.

Hi ivivek,
is it resolved? I have (immediately after the purchase) exactly the same problem :frowning:

No :frowning: I bought a new breakup board but it still does not work. It looks like a problem with the IMP module. I also see 3.3V on the pin when its powered on but it does not work.

Did it ever see negative voltages or voltages above 3.3v on any of its IO pins? That can also fry an imp quite effectively (as you said it was working before)

Hi Hugo,
in my case is the IMP completely new. If the configured wifi network is off, then I can clear the IMP configuration by BlikUp. But after new configuration is the “solid red effect” back. I tried 3 wifi network, 3 cables and powers and lot of wifi configurations. (Small note: before the “solid red” notifies the wifi network connection from IMP, but only for aproximately 1 second)
Any suggestion?

No. Did not see -ve or more than 3.3V on the pins when I checked.

Hello Anyone!

I just received my IMP001 and April board, I configured the LED program to test it out and the IMP kept shutting down. After I unplugged the April board and let it sit a few mins it would start again. Then it stopped working all together. I tested the IMP by applying power directly to the SD pins. The IMP would start right up with 3.3v on its pins directly. Then I tested the April board by measuring the 3v3 pin without the IMP installed. I got .22v I was going to RMA the board but I decided to try re-flowing the solider. I set my toaster oven to 300deg and put the April board in for about 10 min till all of the solider looked shiny again. I turned off the power to the oven and let it sit a few mins to cool down. Then I tested the 3v3 pin again without the IMP installed… IT WORKED! my April board has worked since. I just ordered my second one…

Very cool product.

@mobilecity that sounds like a dead imp (see other threads: solid red is generally either bad power or your device is unable to upgrade its OS). Return it to your supplier?

@mtaivalmaa sparkfun board (red) or one of ours (green)?