Imp shutting shutting off with external power

Greetings all!

So I am having a bit of an issue using the 3.3v output of the imp when migrating from breadboard to perf board.

What is happening is on the breadboard I am powering a single LED / reed switch from the imps output voltage. the shut is on the usb leads along with usb power on breadboard. Fine. I then test my battery setup(still on breadboard) by moving the shut, then connecting the battery leads to VIN/GND. this also works fine, and the project is powered (am using a lipo battery @ 3.7 v 2000 mA).

Now we move to my soldered board with the exact same setup. When I plug the battery to the VIN/GND, the imp does the initial blink ups, and goes to no lights as it should. The minute I attach the pin/voltage out leads to my soldered board headers, the imp shuts off. I tried removing the battery to see if the initial boot up blinks trigger, but nothing.

I’ve noticed this ONLY happens when the 3.3v out / GND pins are connected to the headers even when their is NO current drain coming from the headers.

Now I have been soldering for years, and know my soldering joints/skills are more then up to par so I have eliminated shorting / sloppy solder and crossed traces to create a short as an issue.


Nevermind! Strangely it was the lead pads of a protoboard I had purchased. I tried a different one and everything is swimmingly.

Some people use old protoboards (breadboards) that have been laying around for a while. The connectors develop corrosion over time and you get reduced conductivity where the leads push-in. Good thing you thought about trying a different board.

These were brand new protoboards from sparkfun here:

oh … I thought you were talking about “breadboards”, sorry.

doh! … I didn’t read the part about you soldering. I should read more carefully.