Imp or impee?

Sorry if this is a really stupid question but I sometimes see impee written instead of imp (example on this page in the description of imp.wakeup() ) is this a typo or is impee just a name for an imp?

Not a stupid question. Probably easiest to just refer here for a description of terms …

Re: your reference - the imp itself is the component that really wakes up, but since this is just essentially the same thing as your project/device waking up, the term impee (i.e. imp-enabled device) is likely just used loosely here. (Or, it could just be a minor document oversight that hasn’t been attended to yet).

The term impee did get dropped for this very reason, its a little confusing. It referred to the device that the Imp was controlling as Larry says… I still tend to use the term, but “device” is probably better.

Thanks for the feedback - this clears things up