Imp not updating firmware?

I have an older developer edition Imp that I got right when they were first released. Unfortunately I didn’t get to experiment with it much and only recently have come back to it. I tried the agent demo, but I get an error in the log “[Device] ERROR: the index ‘agent’ does not exist” which I assume means that the firmware is out of date without agent support. I thought it would update once it successfully connected to the cloud, but apparently it isn’t.

It sounds a bit like the problem listed here, except I have a Linksys E4200 router which doesn’t have DNS relay support. Are there any other router settings that I might need to change? Any port forwarding, etc?

Thanks for any help!

That should have auto-updated. Can you give me the mac address?

Sure. It’s 0c2a69000375

Yeah, that mac address has never been seen by our server; can you check on your router (in the DHCP table?) whether this is the actual mac address? It wasn’t until just after that point in production where the MAC address etch wasn’t a manual barcode scan - and so the MAC may not match the laser etch.

Could you also try powering it up on another wifi network to see if it upgrades then?

Copy / pasted from my router’s DHCP table - but it’s the same thing. 0C:2A:69:00:03:75 And I’m sure it’s the Imp because I brought up the table, plugged in the imp, saw it connect (slow green flashing), then refreshed and that’s the one that appeared. If it helps any the device ID is 237d70b236a7c9ee. Thanks.

Oh wow, you’re right. Thanks for the device ID. Yours is so old it didn’t even know to tell the server its mac address. Going to see if we can deal with this better…

I was afraid it might be something like that. Hope we can get this to work! Thanks for your help.

I just realized I could still force this to update in another way. Hopefully it should take the update on the next connection… let me know!

That did it! Thanks for the help!

I have an older imp card that is not updating to the release 27:
software version: (version: 0e967a4 - Fri Jul 19 10:04:28 2013)
mac address: 0c2a690015fd

Can you force an update on this?

@akamlani have done!

Hugo Please Update this Imps,



I also have a couple of Imps that haven’t updated to 27 and are still on the Jul 19 version. I have others that have updated.

Before I add to the list of folks who want you to push an update, can you tell me if the roll-out is complete? If you are still rolling out, I’ll just wait my turn. When your done, if you missed me, I’ll let you know.

Cheers, rledwa2


My Developer Edition imp001 (0c2a69001c1a) is still at Firmware version:
0e967a4 - Fri Jul 19 10:04:28 2013

could you schedule my IMP for a firmware upgrade?


@jfossi @apms all queued.

@rledwa2 it’s still rolling out; if rollout was complete, all your imps would have it. I expect we’ll finish on monday if not before.

@hugo All done. Thank you (especially as it seems that I jumped the gun).

Now at: Firmware version: 9af2fae - release-27.9 - Mon Nov 25 09:58:12 2013

I have a bud redlight and it says connects but when Send a test light signal it doesn’t activate. I purchased the light almost a year ago and never turned it on. I have a dir-655 router and I have un-ticked the DNS relay option that I read in another topic. My imp card flashes green and turns off after about 30 seconds. I was wondering if it was possible to see if my imp is even receiving the update signal. Mac id 0c2a6901f6f5.

@RDPFiRE I can confirm that your imp is running the latest version, yes, however your light appeared to leave the factory without knowing it was a red light.

Turn it off and on, and re-blinkup again, see if it works now.

The card doesn’t light up anymore. I have verified the switch is set more then half way and the imp is seated into the holder and clicks. I have new batteries in the unit installed yesterday. Any ideas?

@hugo excellent customer service!!! The imp lit up after a few minutes and is now connected to the bud redlight service. I was able to successfully send a test signal to my light.

Thank you for your quick response.