Imp not taking Blinkup - Solid Red LED

I have tried to flash my imp with a few different networks, and cannot get any response. From start up, the imp flashes quickly with yellow, red, yellow red green, and then goes to a solid red. The imp shows up in my device log as:

"2014-08-17 13:20:28 UTC-5 [Status] firmware update triggered

But the device itself shows that its offline. I cannot flash new networks to it, and I cannot flash it to clear the settings.

I’m not sure what the problem is. Any suggestions?

Solid red sounds bad for a firmware update (should be short-long green then solid green then reboot), can you return it to your supplier?

I have had the same problem on blinking up the second IMP on my home network. Is there any other solution besides a return? Thanks in advance!

Describe the steps you are taking to blink up. The device (smartphone and app) you are using, and how you actually do the steps. Also describe your physical environment (light or dark area?) If this happened with 2 imps, I’m thinking there is something missing with the blinkup process.

If you’re powered with a known-good USB supply and you’re still getting solid red then I would say it’s likely a return. The most likely thing is that the SPI flash inside the imp has a bad solder joint (when it goes to upgrade, it can’t read the wifi firmware).

Mlseim, One IMP works perfectly. The second IMP I tried to join to the network had the problem using a second April Development board powered by USB. I switched hardware etc. between the two IMP boards and the same problem. First IMP still works perfectly using the same setup (blink up on Android, normally lit room, power source).

Hugo, I am returning today and have already ordered an additional board. I was just wondering if it could be something network specific.

Thanks for the responses!