IMP never shows up in planner

I’m using an imp breakout board. Used the Configuration with WPS button on the phone option. Pressed the WSP button on the router. On the WPS Pin (Optional) screen pressed Send Blinkup. Got 4 Fast Green blinks. Then got green and red blinking lights. Had same problem with 2 different imps.

I presume you did the blinkup within 2 minutes of pressing the WPS button on the router? Does the WPS light come on? (some routers need you to press and hold the button for a few seconds then they start flashing their WPS light).

Can you give any detail about your router make/model?

When I hold the WPS button a light does not come on. I do the blinkup right after I press the WPS button. The router is a Verizon Actiontec M1424-WR Rev E.
Is there a reasonable priced router I can purchase that you know will work?

I googled the Actiontec and as far as the manuals I could find said, though it had a WPS button, it does absolutely nothing right now (they were planning on enabling it in a later firmware revision). See and

The Dlink dir-601 ($22) works fine, including with WPS, but changing router is a bit extreme. If you know your SSID and password, then you don’t need to use WPS - just enter those into blinkup?

I had already tried using the SSID and password using a Samsung Galaxy S2 and a Samsung Galaxy S3. Neither worked. Could it be the phone and not the Actiontec router?

Do you get the quick green blink from the imp at the end of blinkup? If so, then the blinkup has been received ok.

If not, I’ll email you the APK of the new android app which is about to be released…

I uninstalled the old store version and installed the new blinkup.apk. Liked the countdown. The quick green blink did not happen. What do you mean in the email use the “compatibility mode” ?

There should be a tickbox to select compatibility mode in the app; I don’t have an android phone in front of me so can’t tell you exactly where it is…

In the Electric Imp app. First screen - Configure an Imp or Log Out.
When you select Configure an Imp it brings up My WiFi device, Change network, Connect using WPS, or Clear device settings. When you select My WiFi device it
brings up Send Blinkup. It also has a choice Legacy Blinkup Mode? I have tried checking that but made no difference. Am I looking in the wrong place for the Compatibility Mode?

I purchased a D-Link DIR-601 modem. Using the new DIR-601 still not able to get blinkup to work. I’m thinking it may be my phone. I was able to try a Samsung Galaxy S3. It did not work either. What can I try next?

As I said, if you didn’t get the quick green blink at the end of blinkup, blinkup is not working and changing your router isn’t going to help.

SGS3’s are known to work - we have lots of users who have said the app works fine with them.

How are you physically doing the blinkup? You need to cover the side of the imp with your thumb, because in a devboard there’s no housing and hence light leaks in through the side. See here: (and yes, he’s using an android phone)

When you insert the imp into the imp Breakout what should happen. I have 2 imps.
When I plug in one of the imp’s it blinks red once, then red/orange and then green for 60 seconds. Pressing Send Blinkup does not have any affect. On the second imp when you plug it in it just blinks orange. I have watched the video many times and have tried to do it like it shows in the video. Still does not blinkup. Could there is a problem with the imp’s?

Flash codes are documented on the wiki.

The one that’s blinking green is connected and working. It has wifi details and is connecting to the service just fine.

The one that blinks orange has no wifi credentials at all and needs blinkup.

It’s possible it’s faulty (though we have never seen one fail in such a way). What’s more likely is that you’ve just had problems blinking up, and succeeded on one but not on the other. If it’s never been connected then you’d need to use the legacy blinkup option to blink it up on android, or ask someone with an iOS device to do it for you.

I now have both imps blinking Red/Orange and the blinking green for 60 seconds.
Remaining problem the imp does not appear in the planner.

Ok, strange… they should be appearing. What browser are you using?

I am using Google Chrome on a Windows XP pc.

Very strange. Checked the logs and your imps are connected fine, and running the “blank” firmware (which will cause them to appear). Tried scrolling around in the planner in case they’re off-screen somewhere?

I have 2 blank blue boxes on the screen. I scrolled up to top and down to the bottom of the screen. Did not see a box with the imp listed.
Clicked on the “electronic imp” and the “planner” at the top of the screen got blank box with # sign. It went away quickly and back to the main screen.
Clicked on “impees”. Got message “232f324dead3dbee” and below it “237e6c4cead3dbee” on the screen.
Clicked “code”. Got message “No device connected”.

Note: When you scroll the side bar does not seem to move. Not sure if this is a problem.

Thanks for your help. Ken

The two blank blue boxes are the imps… what were you expecting to see for the imp?

When I watch the imp blinkup process video, it states the imp appears in the planner.
The video shows a number 0.094255 and the 0.0940108 on the screen. Mine is showing “Blank”. I have the imp plugged in when I click on the planner. I tried running Hello World but the screen shows "No device connected.