Imp missing from IDE

Hi there

I hope someone can help?!

My Imp has disappeared from my IDE planner. It is connected to my Wifi and I can ping it locally. It was working earlier however when I was playing around in the IDE it suddenly decided not to show up anymore. I have attached a screenshot of what I now get. Router rebooted and Imp ReBlinked.

MAC: 0c2a69045eb6
Model: IMP001

Thanks in advanced


I suspect you have uncovered a bug whereby if you delete the last model in your account, you then can’t see anything. Looking into it now.

Fixed up your account and filed a bug against the IDE…

Thank you Hugo.

I can confirm it has now come back. However inactive and not working. I’ll wait for the debugging guys to get on it :slight_smile:


Ah, I guess this is because the one I restored wasn’t the one which had your imp on it. Will restore the others this afternoon as the debug won’t happen until monday.

Thanks again Hugo. Very much appreciated.

I’m having a similar problem except that I never saw a device. The contents of the Unassigned Devices box is zero. My MAC is 0c:2a:69:00:3e:e1.


Probably not a solution as such… But as I had no code that I needed to keep, I created a new account and blinkedup using the new one. All working now.


@tcoder - what browser are you using? We’ve seen issues with Internet Explorer in the past where devices don’t show up in Unassigned Devices.

Have just blinked up my electric imp, green light is flashing, however, cannot see it on the IDE. The Imp has got an ip ( assigned, however, does not respond to ping (does it have to?), MAC 0c:2a:69:00:02:af
What shall I do next?

Hmm. Yours is a very, very old imp - one of the first made. It should be upgrading at this point, as I believe I see it hitting the old server which just tells it to go upgrade.

However, I don’t see it hitting the upgrade server. This could be an issue with your router’s DNS relay implementation - if you have an option for this on your router, turn it off and try again. The workaround for bad DNS relays went in sometime in 2012 but if your imp is that old, it needs to upgrade to pick it up.

Did not seemed to help, I have also tried other router + mobile hotspot from my mobile prone. None of them seem to help with the issue.
The imp itself between the normal green flashes gives out a 2hz green flash in between. Can else can I possibly upgrade or solve this issue?

If you contact we’ll just send you a newer imp. Given the other original imps upgraded ok though, I’m a little at a loss to explain why yours isn’t. How long did you leave it flashing green for?

Thanks for the help. I left if flashing green overnight - and it still on “trying”

So far no luck getting through them to send me a new device, as bought through a kick starter campaign as a bundle with an arduino kit. Is it not hitting the upgrade server yet? Maybe there is a possibility to upgrade it manually? Any suggestions?

There’s no manual upgrade path - it can only upgrade itself with an encrypted upgrade fetched from our servers. We can send you a new imp, but we can’t help it if it gets stuck in customs… international postage can be a pain.

Unfortunately, I am having the same problem this morning. My April device disappeared from the IDE when I tried to create a new model. I have two older IMP001s. Both connect but the device does not show up in the IDE anymore. The MACs are:
0c2a69000fec (currently connected) and 0c2a6900209b. Please help!

I sent a follow up email @osherl

I have received the replacement IMP’s (2 of them, actually! (IMP001)) and yet non on them are working. Completely identical issues, blink up successful, some exchange of data when connected, green blinking all night and still cannot see any of them on the IDE. Please help! Shall list all MAC’s in the evening, however, old one 0c:2a:69:00:02:af had the same issues.

second imp mac (currently connected) is 0c2a69000345