Imp LED doesn't comes up

Hello,

I’m attempting to troubleshoot an Electric Imp for my lab. Yesterday night it was working just fine, but now I can’t get it to work. No matter the power source, the light won’t blink. It blinked once and then stopped and never again. I’ve seen a similar question here:

https://forums.electricimp.com/discussion/3839/imp002-evb-blinkup-status-light-not-working#latest

However I think I have the imp001 (http://www.amazon.com/WiFi-Environmental-Sensor-LED-kit/dp/B00ZQ4D1TM/) since the kit looks exactly the same and I have the Env tail attached to it.

One thing I noticed is that the Env tail heats up A LOT (honestly this has been my way to realize something is happening in there with energy flow). I thankfully found a usb in my house to plug it in for power, but I also have tried with an Energizer 9 V battery which my lab had soldered it in on the +P/-P.

I don’t have anything to verify the voltage right now on the imp. Any insights on this? The cellphone was paired sucessfully last night and I still have the screen here, along with some tests I run which the device responded. But that was it, nothing today. (curiously enough, i left everything as is other than unplug from the battery.

While I was testing the weather station code on it yesterday, I realized it sampled once or two, then went to sleep and it wouldn’t resurrect afterwards (no matter the delay if 600s or 5s). I wonder if both issues relate.

Edit: I found out that changing the ENV tail to the LED tail makes it work just fine (also without any tail). So I am led to believe there is something wrong with the ENV tail. I also realized the ground pin is slightly bended, and the env tail does heat up a lot. However, I started wondering if it may be an issue with enough energy being supplied. Is it safe to connect the usb to an adaptor to them plug on the wall or would this fry the whole imp?

Thanks!

If the imp isn’t getting hot then that’s probably ok. If the env tail is getting hot then I suspect it’s been plugged in incorrectly at some point; the components on the env tail take essentially zero power when they’re working correctly - eg a temperature sensor isn’t much good if it self-heats.

A wall adaptor isn’t going to make the env tail work; the imp takes much more power than the env tail.

Hi Hugo,

Now that you mentioned, you are correct: When it was working yesterday night, the temperature readings were at 74C - 86C, which was probably what was going on. I think past that it just overheat so much that it doesn’t work anymore.

I just recently joined the lab, so I am unware of what could have been done to it (in fact I didn’t even know it could be un-plugged since I first saw it connected). It only started running today when I took that piece off.

  1. So it is safe to assume the Env tail is a gonner or is there a better way to check? Do you think a slight tilted ground pin can fry another env tail or that shouldn’t be an issue? The interface is so simple that I can’t even begin to imagine how it could have been pluged wrongly!

  2. The imp and the LED tail works just fine. Which is kinda sad, since my application requires sensors! I saw around I can only get another tail if I buy the whole kit altogether. Do you have any suggestions of a tutorial that builds a weather station without the env and wouldn’t require soldering abilities?

Thanks.

Check all the peripherals. You may find that just one of them isn’t working - you could always desolder that one and the rest may still work ok.

I doubt a tilted ground pin would have caused this, but plugging it in offset or reversed could have.

I’m afraid the tails are only in the kit as selling individually is too much overhead. Buy another kit and find a different use for your now spare imp?