Imp ide server broken

I can’t load the IDE (chrome and firefox on Mac OS X). It starts, then stops at 33% done.
Chrome developer tools reports a 500 and 404 error.

What’s going on?

Remote Address:
Request URL:
Request Method:GET
Status Code:500 Internal Server Error

and then

Remote Address:
Request URL:
Request Method:GET
Status Code:400 Bad Request

Ah, so ide/v3/device/new returns:
{“code”:“InternalError”,“message”:“Cannot read property ‘id’ of null”}

Maybe cause I haven’t been able to blink up a device? Everytime I run blinkup on iOS app the app crashes.

Really pretty disappointing – the ide crashes and refuses to load; the iOS app crashes immediately after hitting ‘blinkup’

Sure sounds like this and blink up app issues are related - we’ve bit seen other reports so I’m suspicious that the issues are related to your account.

Did you just create a new account recently?

I’ve just signed up, and the IDE also fails to load for me; it gets to 67%, then fails due to a cross-origin request being blocked:
XMLHttpRequest cannot load No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘’ is therefore not allowed access.

@pauln which browser are you using? I just tried creating a new account and it all worked fine for me. Chrome 43 on a mac.

I can see your account is activated (from the email link), and I can see what looks like normal IDE usage traffic from your IP address.

I managed to successfully connect an Imp via BlinkUp on the second attempt (using the retry link at the bottom of the failure screen on the Android app - no change to settings), and now the IDE works! I also logged into the IDE using Firefox (was previously using Chrome), but now it works in Chrome too - so that probably wasn’t relevant.

…also tried firefox 38.0.5 (mac) and didn’t have any issues with a newly created account.

Interesting, so it only failed for you before the first device was connected? My (newly created) account has no devices on it and seems to work fine in both chrome and firefox. Did you save any more info on the cross-origin error that I can pass to the web guys?

Still not working for me (same 500 error on the e-imp server).
Yes, this is a newly created account (I created the account right after MakerFaire), but this is first time I activated and logged in.

No device on my account because blink up app crashes everytime I try it.

@mikecarlton Some of your account data is corrupted, oddly enough. I’ll look into fixing this for you tomorrow.

@mikecarlton We’ve fixed some things on your account, and the IDE / BlinkUp should hopefully be working properly now. Please let us know.