Imp device disappeared


#1

Hello i had some wifi problems and suddenly when my wifi problems were solved i saw in my imp ide, that the device disappeared. Devices(0) then i did the blink up process again,
Still no connection detected. However it blinks green for 1 sec and then off for 2 secs and so on and so on, until it stops blinking…
This “no blink” means that its normal operation. Why does it not connect to the ide? or show up in the phone???

regards


#2

Can you provide a mac address so we can look?


#3

I also do not have access I have nothing, more program it’s been a long time since I did not work on the electric imp how do you get the id?


#4

I can not find my programs and my devices anymore in electric imp ide


#5

Hugo, since then if i program again my imp it connects.
But if i remove it and insert it again i keep getting the Searching for WiFi network blink code…
is anything wrong in the cloud?
My network is visible also to a pc and mobile phones and no problems with those equipments reaching the web.


#6

@ramstein74
Just a wild shot in the dark …
How is the imp powered?
If a battery, it could be slightly low in voltage. I had a similar thing happen once.
If not a battery, then nevermind this post.


#7

There are no cloud issues, however the 36.12 release that went to developers appears to have problems with certain 802.11n access points.

We addressed this in 36.13 which is pushed to all developer devices - 36.x had not yet rolled to production devices.

From the black box logs on your device, you appeared to be in a weak signal area - we saw a disconnect with this error:

00:02:13.75 WLC_E_ROAM:WLC_E_STATUS_NO_NETWORKS:WLC_E_REASON_LOW_RSSI

#8

i have the router in my desk.
I tried again with another imp
it connects , then disconnects

Device ID Online
23370bb030728cee
Agent ID Running
9tnBbOf_sONP
In Account
ramstein74
Product
Cantina
Device Group
Cantina
Actions
Select
DETAILS
LOGS
HISTORY
Device Info
Device ID 23370bb030728cee
MAC address 0c:2a:69:00:47:bb
Name
Device Status Online
Free Memory 84660 bytes
imp Type imp001
impOS Version 1ae4c87 - release-36.13 - Wed Dec 20 10:52:30 2017 - production
Agent Info
Agent ID 9tnBbOf_sONP
Agent Status Running
Agent URL https://agent.electricimp.com/9tnBbOf_sONP
Connection Info
IP Address
Last Enrolled 2017-12-22 10:17:36 +00:00
Plan ID ccc07468498f73e4
RSSI -43 dBm

Any ideais?


#9

Can you provide the code it’s running? I’m suspicious of your router as we’ve not had any other reports of issues on 36.13 (all developers are on this now).

Most recent connect was at 2017-12-22 10:17:37 UTC, and it got disconnected by the server for not responding at 2017-12-22 10:27:09 UTC.

The black box logs from this connect show that it is really having problems connecting to your AP; in fact, I’ve never seen this error before: WLC_E_MULTICAST_DECODE_ERROR:WLC_E_STATUS_SUCCESS:WLC_E_REASON_INITIAL_ASSOC

What is the AP type/setup?


#10

I´m using a linksys router. Strange issue because i have other imps on the same router and this is the only one in trouble.
the router is a linksys wrt1900ac
I will take this imp home and try there with my wireless router…
What a bad present for Christmas :slight_smile:
Thank you


#11

Trying at home right now. Not corporate firewall in the middle. Just a regular home user with a speedtest off 36Mb/s download in my pc.
And it still does not work. The blink up is successfull but after that it blink red.
The device is is 2341b84…3dbee

Any help?


#12

Hugo, i found something.
I created a new account for me and from there i did the blinkup again. and guess what. It works.

Can you explain why?

You have a problem in your cloud.
Its not the RSSI as you suggested. The migration eventually has a problem that is blocking my imp.

Regards


#13

Really can’t explain that, as it wasn’t connecting at all (hence an account issue is not possible - the device has no idea what account it is in, that’s a server-side concept).

Was that the first time you did a blinkup again? As I noted above, there seemed to be a problem with wireless credentials… well, possibly the multicast key - did you change WPA encryption type (or router!) since the original blinkup? There are different multicast options, AES/TKIP and AES/CCMP, AES refers to the unicast encryption type and TKIP/CCMP refer to the multicast type - if you had the incorrect type them maybe it wouldn’t hear multicast/broadcast packets which would certainly prevent some things like DHCP working.

A re-blinkup causes the imp to re-detect the encryption type in use.

This doesn’t really explain why it started working again though, unless the password was mistyped when you did the first blinkup when you got home - which would explain the blinking red.

Try blinking it back up to the original account?

(edit: the imp ID you quoted changed from 233… to 234… … did you change which device the imp card was plugged into?)


#14

Actually I think I know what is happening - you’re getting confused between imp001 cards (which have a mac address) and imp devices (which have an ID starting with “23” generally).

The imp card you originally said had a problem, 0c2a690047bb, has not connected since 12/22 at 10:17 UTC like I said 3 days ago. This was last seen in device 23370bb030728cee, but 10 mins before was seen in device 2341b84cead3dbee.

With the imp001, it is NOT the card that appears in the IDE. It is the device the imp is plugged into which appears in the IDE. Whatever device the imp is plugged into, it will run the appropriate code for that device - in effect you can swap imp cards that are blinked up to the same account around and nothing changes in the IDE - no new devices will appear. The server sees the card has changed, but it’s still on the same account and in the same device, so it carries on silently operating as it did before, with the same agent ID and everything.

I can see this:

0c2a690047bb was in 2341b84cead3dbee on 12/22 at 10:17 UTC
0c2a69001cd2 was in 2341b84cead3dbee 20 mins later
You then blinked up 1cd2 in 2341b84cead3dbee at 2017-12-23 21:40:16 on a new account.

When you moved it to a new account, you would see a new device appear because there’s no code associated with 2341b84cead3dbee in that account.


#15

Yes i did changed the device from 233 to 234 , but the problem was originally with 234.
I only have 234 now because i realized that its not imp card or imp device problem.
I tried blinkup with the original account and no success… tried then with the new account and it works…


#16

Pretty sure this is just you not being able to find the device.

Blink it up back onto the first account again and we’ll work through finding it.

Are you using legacy IDE or impCentral?


#17

Back to my company department again after christmas…
Using the same router and the new account i did the blink and it connects with no disconecting message…

Then tried blinking on the first account. The blinkup is successfull but then it goes blinking the red light…
Waiting your help Hugo…


#18

Need more details - which mac address, which device ID, which account and timestamp in UTC. You can PM this detail if you want.