IMP connects but never shows up in the devices

We tried blinking up the device multiple times, it connects to wi-fi (the LED turns green) but does not show up in the IDE.

Mac: 0c2a69046c6d and MAC: 0c2a69046c94
IC: 4491A-IMP001

Try refreshing your browser.

What browser are you using, BTW?

I am using Chrome…
I refreshed multiple times as well.

We have tried firefox as well… Can somebody please check the device logs and let me know the condition of the device.

0c2a69046c6d last connected around the time of your last post, but is not associated with any code model, so you should find it under ‘Unassigned devices’ in the left hand menu.

0c2a69046c94 is active but associated with an account that has a different email address from your forum one. Send me a DM with your IDE email address for more details.

Thank you so much Philmy.
I am able use the device 0c2a69046c6d now.
But if I delete the device from my account and give it to other developer, it shows in unassigned device of both of our IDEs. Is this is the expected behavior?

An imp can be listed in more than one developer’s IDE but the code models remain private. The imp will be active in the IDE of the person who last blinked it up.

If you give an imp away you can manually remove it from your IDE by hovering the mouse over the device ID in the left hand menu, then click the cog icon followed by the ‘Delete Device’ button.