Imp connects, but never shows up in devices?

Hi - my imp was working fine, but now just will not show up.
I’ve tried re-blinking it, which works fine, but always get the same result, i.e. a successful connect but nothing showing in the IDE.

Any ideas?

Your atsha id chip is dead (returning all zeroes for the device unique ID).

(Just to clarify: that’s not psychic debugging; I checked the log files on the server)

I am having the exact same problem with a brand new imp

@echeever I see from the logs that your imp last connected a few minutes after your post and has the latest 30.22 impOS. If it was brand new it may have taken a couple of minutes to upgrade. It’s now associated with your “Hello World” code model so I presume you’re now up and running…?

I have a same problem. I can connect to my WIFI. I checked my WIFI router and saw it’s connected. I also verified with pinging. But I can’t see my device on the IDE website. My device MAC is 0c2a69000104.
Light sequence: green/off -> repeat. Then later green/amber few times then all off. So I guess it’s in normal operation but I don’t see it in the IDE. Thanks for help me debugging this.

@aikudo - everything looks good on our end. Try refreshing your browser if you haven’t already.

Also - what browser are you using?

Hi guys,

I’m having the same problem. I ran the Blinkup app and the imp is connected to WIFI, I’m getting a 4 green light sequence. However it’s not appearing as a new device in the Electri Imp IDE. My mac is 0c2a6905374a and I’m using Chrome and IE 11 as browsers for the IDE.

All looks fine with your imp too. When you say “not appearing as a new device”, remember that if it’s plugged into a device you were using before, no new device will appear (because it’s DEVICES that appear in the IDE, not imps).

Could that be it?